summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-14 05:48:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-14 05:55:37 +0100
commit24d14cb2a30dd069ad4ca3767557e201b32ec5a4 (patch)
treee219c9cf30970b895adab856ed8efb269935f9e2 /dev-python/cmd2/cmd2-1.0.1.ebuild
parentnet-im/telegram-desktop: drop old beta versions (diff)
downloadgentoo-24d14cb2a30dd069ad4ca3767557e201b32ec5a4.tar.gz
gentoo-24d14cb2a30dd069ad4ca3767557e201b32ec5a4.tar.bz2
gentoo-24d14cb2a30dd069ad4ca3767557e201b32ec5a4.zip
dev-python/cmd2: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cmd2/cmd2-1.0.1.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-1.0.1.ebuild b/dev-python/cmd2/cmd2-1.0.1.ebuild
new file mode 100644
index 000000000000..dd0714d43c10
--- /dev/null
+++ b/dev-python/cmd2/cmd2-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}