summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-12 22:20:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-12 22:21:06 +0300
commitc76c2d6b113481dcb14462aab0ee273937b05801 (patch)
tree94614bde71cfc0b48b729044f046de4b16d86a73 /dev-python/colorlog/colorlog-6.6.0-r1.ebuild
parentdev-python/configobj: enable py3.11 (diff)
downloadgentoo-c76c2d6b113481dcb14462aab0ee273937b05801.tar.gz
gentoo-c76c2d6b113481dcb14462aab0ee273937b05801.tar.bz2
gentoo-c76c2d6b113481dcb14462aab0ee273937b05801.zip
dev-python/colorlog: enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/colorlog/colorlog-6.6.0-r1.ebuild')
-rw-r--r--dev-python/colorlog/colorlog-6.6.0-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/colorlog/colorlog-6.6.0-r1.ebuild b/dev-python/colorlog/colorlog-6.6.0-r1.ebuild
new file mode 100644
index 000000000000..440cff7d948f
--- /dev/null
+++ b/dev-python/colorlog/colorlog-6.6.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Log formatting with colors"
+HOMEPAGE="https://pypi.org/project/colorlog/ https://github.com/borntyping/python-colorlog"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv x86"
+
+distutils_enable_tests pytest