summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 07:21:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 07:54:24 +0200
commit36209d729c595df28cc5a9ea6ede978004c4f5d5 (patch)
treefd4b7469841ad55b89cb0e63c1e7bd94b8c7da3d /dev-python/configargparse
parentdev-python/netcdf4-python: Bump to 1.5.7 (diff)
downloadgentoo-36209d729c595df28cc5a9ea6ede978004c4f5d5.tar.gz
gentoo-36209d729c595df28cc5a9ea6ede978004c4f5d5.tar.bz2
gentoo-36209d729c595df28cc5a9ea6ede978004c4f5d5.zip
dev-python/configargparse: Bump to 1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configargparse')
-rw-r--r--dev-python/configargparse/Manifest1
-rw-r--r--dev-python/configargparse/configargparse-1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/configargparse/Manifest b/dev-python/configargparse/Manifest
index 46195da88001..034348fd353a 100644
--- a/dev-python/configargparse/Manifest
+++ b/dev-python/configargparse/Manifest
@@ -1 +1,2 @@
DIST ConfigArgParse-1.4.1.gh.tar.gz 30343 BLAKE2B 8aaed3b0e85b4006c04e7910c6f7ae2c2a07d586ade777eedf078afeea4561a4504614484316afd9d234b2871c0cc45ef47f30254797f9df260373309cf67927 SHA512 304d5981c5685188edb22a63966d25a8943e4c443f2aefc323492f141885f50657e9f9200514df65683f1e13e64173d4def80cdbebcff941c3ee66ff4af0cbd4
+DIST ConfigArgParse-1.5.gh.tar.gz 30375 BLAKE2B 8a3c0091dc4049e9f84eb6209f7a62cafab0c0357d4d17304520b2855d60cdb68e63607068612bc99b07709f1fde4b0a3f11dbf4e45087968eab901d2b20b79f SHA512 82121fa6e8f734898674220b888dd3670368389a5cbd40e87d9188fa55d4378fdf480cc7dc003a4b9eadc1951fa8fc6141e9c0b079321cfe70c64bebacfb8944
diff --git a/dev-python/configargparse/configargparse-1.5.ebuild b/dev-python/configargparse/configargparse-1.5.ebuild
new file mode 100644
index 000000000000..43ba113e8698
--- /dev/null
+++ b/dev-python/configargparse/configargparse-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="
+ https://github.com/bw2/ConfigArgParse/
+ https://pypi.org/project/ConfigArgParse/"
+SRC_URI="
+ https://github.com/bw2/ConfigArgParse/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}