summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-11 06:55:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-11 09:49:06 +0200
commitcc53a6110115e79cf5a634c6f1819943968df985 (patch)
tree1fa3c17f414eed74475623238226849e60424ecb /dev-python/configargparse
parentdev-python/pypy3: Bump to 7.3.1 (diff)
downloadgentoo-cc53a6110115e79cf5a634c6f1819943968df985.tar.gz
gentoo-cc53a6110115e79cf5a634c6f1819943968df985.tar.bz2
gentoo-cc53a6110115e79cf5a634c6f1819943968df985.zip
dev-python/configargparse: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configargparse')
-rw-r--r--dev-python/configargparse/Manifest1
-rw-r--r--dev-python/configargparse/configargparse-1.2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/configargparse/Manifest b/dev-python/configargparse/Manifest
index a3e3fd8a9f68..2acb6e306447 100644
--- a/dev-python/configargparse/Manifest
+++ b/dev-python/configargparse/Manifest
@@ -1,3 +1,4 @@
DIST ConfigArgParse-1.0.gh.tar.gz 26460 BLAKE2B 0dc83125116139e9447da8a9c660ac67db8b83a3b09c1e3ff148e09053ca10d2ef01447fd055d11804ad3903134043672ce7f458d990ff69c0ae07024539a3c4 SHA512 8e2af22dfa08bcf4665289285cc8f94aca00b650cd9521e9c02d4d83b546f4d79f2fd2cae2818ad0f2d38a16907e145ca7165071b78c557fe0be1797609e1cae
DIST ConfigArgParse-1.1.gh.tar.gz 27134 BLAKE2B 41e76be8932436414b4a159fe7a653594b8a1e5c3d981b2793912893924db18020489a76abbbdd71076650568e4b67b1f56e4d9161c25c5723877cc8781fbb11 SHA512 a4d02d669151087fca799bad4ed2381b7487cd749055f474f17a8b0aa4a6a643d161416510b0ee80427d59c34ce4d17710730f2d23d9b74e853dadb4d8e78260
+DIST ConfigArgParse-1.2.1.gh.tar.gz 27797 BLAKE2B e6e8468e15090a2915a3c2a10446c2797553eeee48f61d29218ad4935f24e92aeb4319609450d40fa1e87f9b02e9a8517fa876acf4b20ee4bc35b38daeadf99d SHA512 38fd6be13d0582e453a5d5dee1bf4a295bfe2be10b12535a8a0a597b3b726feee4fe4b27f354441c5fb53bf6b6bc11eca978d9f07c5bced6d2246996711af13f
DIST ConfigArgParse-1.2.gh.tar.gz 27780 BLAKE2B aa8e26b871c48b43a5b3527a59c463a4ce982f945f29255aa15d19ffc7e5373efef401d9ecaffdf9059865484e9ab9bd07cc9f36c685675d7d9105b03b1ae1a0 SHA512 50a125e2c03f5ec0ccd843a44109bd065c39cb3a5b72cf0ca0ab361cc1a97de56f2eef0bf04aac2cda4b302ae67cd422bf04c8e09b1bbedca3ae19a28a5f2eb9
diff --git a/dev-python/configargparse/configargparse-1.2.1.ebuild b/dev-python/configargparse/configargparse-1.2.1.ebuild
new file mode 100644
index 000000000000..be7d7f5bac5a
--- /dev/null
+++ b/dev-python/configargparse/configargparse-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="https://github.com/bw2/ConfigArgParse https://pypi.org/project/ConfigArgParse/"
+SRC_URI="https://github.com/bw2/ConfigArgParse/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ local -x COLUMNS=80
+ esetup.py test
+}