summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-18 11:41:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-18 11:44:26 +0300
commit84fc5bfad74bd1fbc9b95251d48007b601fae414 (patch)
tree6de95def8b96b18f2025e71cd0d23ec0762ebe31 /dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
parentdev-python/configshell-fb: enable py3.10, py3.9 (diff)
downloadgentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.tar.gz
gentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.tar.bz2
gentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.zip
dev-python/configshell-fb: add 1.1.29
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/configshell-fb/configshell-fb-1.1.29.ebuild')
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.29.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
new file mode 100644
index 000000000000..378a56f89e46
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]"