summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-22 23:32:43 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-23 00:40:16 +0100
commit9749fbd7b8ecde3764156e3bb18b33f1af918524 (patch)
tree453620ccf93f09b258fba1f1f3702e15f83d3ed7 /dev-python/constantly
parentdev-python/incremental: add Python 3.8 support (diff)
downloadgentoo-9749fbd7b8ecde3764156e3bb18b33f1af918524.tar.gz
gentoo-9749fbd7b8ecde3764156e3bb18b33f1af918524.tar.bz2
gentoo-9749fbd7b8ecde3764156e3bb18b33f1af918524.zip
dev-python/constantly: add Python 3.8 support
Re-enable tests. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/constantly')
-rw-r--r--dev-python/constantly/constantly-15.1.0-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/constantly/constantly-15.1.0-r1.ebuild b/dev-python/constantly/constantly-15.1.0-r1.ebuild
index e3b36e5d7bb5..fca5a2c60885 100644
--- a/dev-python/constantly/constantly-15.1.0-r1.ebuild
+++ b/dev-python/constantly/constantly-15.1.0-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -17,9 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=""
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}
test? ( dev-python/twisted[${PYTHON_USEDEP}] )
"