summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-01-17 14:12:28 +0500
committerPatrice Clement <monsieurp@gentoo.org>2018-01-25 23:49:19 +0100
commitad1cbcb94582e5a4d579ecb616e9260ee99392f0 (patch)
tree2fa4502787333056f982f184ca8000d517102b3d /dev-python/construct/construct-2.8.21.ebuild
parentx11-misc/lightdm-gtk-greeter: update GTK+ icon cache. (diff)
downloadgentoo-ad1cbcb94582e5a4d579ecb616e9260ee99392f0.tar.gz
gentoo-ad1cbcb94582e5a4d579ecb616e9260ee99392f0.tar.bz2
gentoo-ad1cbcb94582e5a4d579ecb616e9260ee99392f0.zip
dev-python/construct: version bump to 2.8.21.
Added support for Python 3.6. Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6889
Diffstat (limited to 'dev-python/construct/construct-2.8.21.ebuild')
-rw-r--r--dev-python/construct/construct-2.8.21.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/construct/construct-2.8.21.ebuild b/dev-python/construct/construct-2.8.21.ebuild
new file mode 100644
index 000000000000..70ec0fd0fff1
--- /dev/null
+++ b/dev-python/construct/construct-2.8.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}