summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-25 20:54:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-25 20:54:55 +0300
commit1d77bc1d9d0aa59f0427b4dc2c434ca3e15effe3 (patch)
tree517d5a40ebb8998ff4dc676bf369e0714534788b /dev-python/construct
parentdev-python/progressbar2: drop 3.39.3 (diff)
downloadgentoo-1d77bc1d9d0aa59f0427b4dc2c434ca3e15effe3.tar.gz
gentoo-1d77bc1d9d0aa59f0427b4dc2c434ca3e15effe3.tar.bz2
gentoo-1d77bc1d9d0aa59f0427b4dc2c434ca3e15effe3.zip
dev-python/construct: enable py3.10, use EPYTEST_IGNORE
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/construct-2.10.67.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/construct/construct-2.10.67.ebuild b/dev-python/construct/construct-2.10.67.ebuild
index 89b9b60fbf75..4ec846464409 100644
--- a/dev-python/construct/construct-2.10.67.ebuild
+++ b/dev-python/construct/construct-2.10.67.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A powerful declarative parser for binary data"
@@ -25,9 +25,9 @@ BDEPEND="
distutils_enable_tests pytest
-python_test() {
- epytest --ignore tests/test_benchmarks.py
-}
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)
pkg_postinst() {
ewarn "Version 2.10.x has significant API and implementation changes from"