summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-13 08:55:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-13 09:14:46 +0100
commitce34f8fcaffb691c4fc8781c011c8917777aed63 (patch)
tree3374c25c6fe2ab24585d1c0b5cfa6b305f160087 /dev-python/construct
parentdev-python/boto3: Bump to 1.17.7 (diff)
downloadgentoo-ce34f8fcaffb691c4fc8781c011c8917777aed63.tar.gz
gentoo-ce34f8fcaffb691c4fc8781c011c8917777aed63.tar.bz2
gentoo-ce34f8fcaffb691c4fc8781c011c8917777aed63.zip
dev-python/construct: Bump to 2.10.60
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.60.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 9c30ad8519e0..6865c7ba1926 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -2,3 +2,4 @@ DIST construct-2.10.56.tar.gz 1184110 BLAKE2B 01ce1800970826ae3584a9733de171e04d
DIST construct-2.10.57.tar.gz 1184585 BLAKE2B abaeebf5872cc97cc67d47cf79370fecdb1abafb62fa80b6acfa63de9087f70fa67fd69e90ab4e78e7ac179c1bb1011529e34201c3c2270e1a2651c97cc678b2 SHA512 ef2f0bbcf4cbcf4862033b16ccb428f84d63ca5c867157b47e38b441cb439c953b543cf69f352c0542525fd07b37d1b3b68910ae5331c482e75b4af937e116a1
DIST construct-2.10.58.tar.gz 1184881 BLAKE2B d1dfa005542505b0a154f3c0ae74a1708747b1e7b9f5dc650b924169fa54620719bdf5bb868e616ae58e8890f547eaf3bad5b02ef1f7f7ffeeadffaa87413041 SHA512 8547847e3fa15c020ab7d178b229c5b93744b48497c4cf809a93527be5776eacd52783a0fa38583d694c262c119835c989fcbe0936eb247ca844d252c4bdebb5
DIST construct-2.10.59.tar.gz 1185999 BLAKE2B 35c861d5d4f5d68a158f25cffccda76621e0fe901e5f8bdf9c0aea61e3ddd2174c71767601be3533092a6a28748597cd1a044e4721436748b9a2dac81b81b41b SHA512 bf5867efdb9e1a27ddede6844f5f3466714e38dd97aae09c6990582989801605eebf90099fb3a0ab78deaed4f3b6be38421b635f6332461efd033d5fb8c2c1af
+DIST construct-2.10.60.tar.gz 1185983 BLAKE2B e263c15db9d8055db854508f767906e51fb260c47e2df17e2786277a3ed66e9a8599f21299b21d0629997c6ce2afd7651e18aee4c7f22d3e38bdc5db5bd53bd4 SHA512 597e4fd9f0264450fe221e100041a897d25794bea4dd5cbf5f58df8a0829a34490daff10764e6329ade165df631ddce661dceae4417d8f55472b2fad2a53e53d
diff --git a/dev-python/construct/construct-2.10.60.ebuild b/dev-python/construct/construct-2.10.60.ebuild
new file mode 100644
index 000000000000..09b4e4cc3146
--- /dev/null
+++ b/dev-python/construct/construct-2.10.60.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm tests/test_benchmarks.py || die
+}
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}