summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 10:36:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 11:36:04 +0200
commitc4690fe28c824453d681972e1c6a4e753dba9847 (patch)
tree2ec25bb04b1830b3b104e59a1ce39ff6af228f25 /dev-python/cov-core/cov-core-1.15.0-r2.ebuild
parentgnome-extra/gnome-shell-extension-gsconnect: Bump to v42 (diff)
downloadgentoo-c4690fe28c824453d681972e1c6a4e753dba9847.tar.gz
gentoo-c4690fe28c824453d681972e1c6a4e753dba9847.tar.bz2
gentoo-c4690fe28c824453d681972e1c6a4e753dba9847.zip
dev-python/cov-core: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cov-core/cov-core-1.15.0-r2.ebuild')
-rw-r--r--dev-python/cov-core/cov-core-1.15.0-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cov-core/cov-core-1.15.0-r2.ebuild b/dev-python/cov-core/cov-core-1.15.0-r2.ebuild
new file mode 100644
index 000000000000..83c5764ec713
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://github.com/schlamar/cov-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"