summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-10-18 18:07:46 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-10-18 18:07:46 -0700
commit2db21f40502d51c8aa5331b380c5340db0b53d80 (patch)
tree8b41537245d5ae40b6f3134e9ff6ba62d309557c /dev-python/cov-core
parentapp-misc/vifm: Keyword 0.11 arm64, #813381 (diff)
downloadgentoo-2db21f40502d51c8aa5331b380c5340db0b53d80.tar.gz
gentoo-2db21f40502d51c8aa5331b380c5340db0b53d80.tar.bz2
gentoo-2db21f40502d51c8aa5331b380c5340db0b53d80.zip
dev-python/cov-core-1.15.0-r3: Strip *.pth files, fix pypy3 install
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/cov-core')
-rw-r--r--dev-python/cov-core/cov-core-1.15.0-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/cov-core/cov-core-1.15.0-r3.ebuild b/dev-python/cov-core/cov-core-1.15.0-r3.ebuild
new file mode 100644
index 000000000000..932a3334d2b7
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://github.com/schlamar/cov-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+
+python_install() {
+ [[ ${EPYTHON} == pypy* ]] && addpredict "$(python_get_sitedir)/init_cov_core.pth"
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}