summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-03 10:34:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-03 11:22:48 +0300
commit351b91fd14c558bbfaac05191cd38a35fca7e7f1 (patch)
treefad7f2348f53c86f9579d31e64773a0b982cbc81 /dev-python/coverage
parentdev-python/django-js-asset: enable py3.10, cleanup tests (diff)
downloadgentoo-351b91fd14c558bbfaac05191cd38a35fca7e7f1.tar.gz
gentoo-351b91fd14c558bbfaac05191cd38a35fca7e7f1.tar.bz2
gentoo-351b91fd14c558bbfaac05191cd38a35fca7e7f1.zip
dev-python/coverage: add 6.0
Closes: https://bugs.gentoo.org/812335 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-6.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 16dd05096223..e533bb475961 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,2 +1,3 @@
DIST coverage-4.5.4.tar.gz 385185 BLAKE2B 9d040bff13cebd1cb7147f15c3ec03bb08648cf801b5b2bb046a6b5bcadb3d3886be8bf0a624d225f25d10a5ca82fe5fb88f55e44e92a0a3285836b837972970 SHA512 ba534e04fe35cbadc4b16735f25c08f579a49a6677ec106680f222f2dfb3d0f1e011d0962f1c2108c375173ac4588bea1619ecda05ff9ba6fd888daddfd27b0e
DIST coverage-5.5.tar.gz 691258 BLAKE2B 66bf340956b760d996ce424f977b407eb74062db56108e4910459dbcb7c271820ca655a648021763aede1c4d87c44524cea0cb34f969f203f630d48cf15b05b4 SHA512 fb78b4920a2f18afb9545a6f13910f491708443965881954fff6ee8553ab3d6bd898f7a95df1091435e8d5627ac850b880a6233e716a6acb934ecc195ec2ee52
+DIST coverage-6.0.tar.gz 719495 BLAKE2B fa2768cc34f5c8e5e1b0bd328dda4b83bccae4bcb37b1e2ea8ff9a7fad973239a264f12cea7fae7ed129abe1a7aa86b43e2e32fcfd5c4de2077c8b32f405cd3a SHA512 b9a5dcb2aeb8517a9a52feadfd817727086d88682d9d93d65d9f4d7b6116d8eca1ecceaccc98ff34ca2fb1c2d4dc457d0d58d387465e67970ae4df0f4c9f7ca5
diff --git a/dev-python/coverage/coverage-6.0.ebuild b/dev-python/coverage/coverage-6.0.ebuild
new file mode 100644
index 000000000000..202b422e1551
--- /dev/null
+++ b/dev-python/coverage/coverage-6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+#IUSE="test"
+# The tests are impossible to appease. Please run them externally
+# via tox. Or fix the ebuild if you have hours of time to spend
+# on something utterly useless.
+RESTRICT="test"
+
+#BDEPEND="
+# test? (
+# dev-python/PyContracts[${PYTHON_USEDEP}]
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/hypothesis[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+# )
+#"
+
+src_prepare() {
+ # avoid the dep on xdist, run tests verbosely
+ sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ pushd tests/eggsrc >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+
+ "${EPYTHON}" igor.py zip_mods || die
+ "${EPYTHON}" igor.py test_with_tracer py || die
+
+ # No C extensions under pypy
+ if [[ ${EPYTHON} != pypy* ]]; then
+ cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
+ "${EPYTHON}" igor.py test_with_tracer c || die
+ fi
+
+ # clean up leftover "egg1" directory
+ rm -rf build/lib/egg1 || die
+}