summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-02 01:08:32 -0500
committerMike Frysinger <vapier@gentoo.org>2016-03-02 01:11:23 -0500
commitd262c2eb3f8606dad0fa2fc560753354e4f8bee9 (patch)
tree01c8391db23d71acee6f9491cbec47ad869ad49d /dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild
parentdev-util/cucumber-rails: add 1.4.3 (diff)
downloadgentoo-d262c2eb3f8606dad0fa2fc560753354e4f8bee9.tar.gz
gentoo-d262c2eb3f8606dad0fa2fc560753354e4f8bee9.tar.bz2
gentoo-d262c2eb3f8606dad0fa2fc560753354e4f8bee9.zip
dev-python/cryptography-vectors: verison bump to 1.2.3
Diffstat (limited to 'dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild')
-rw-r--r--dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild b/dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild
new file mode 100644
index 000000000000..752c8492a847
--- /dev/null
+++ b/dev-python/cryptography-vectors/cryptography-vectors-1.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Test vectors for the cryptography package"
+HOMEPAGE="https://pypi.python.org/pypi/cryptography-vectors/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}