summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-30 15:40:45 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-30 19:05:29 +0100
commit19a8e78eab2320df5709d981a092d848df30fee1 (patch)
tree20e39fa1a0bbe560c1d1b802cea21f6983133985 /dev-python/cryptography/cryptography-1.6.ebuild
parentdev-python/pytest-xdist: Enable pypy3 (diff)
downloadgentoo-19a8e78eab2320df5709d981a092d848df30fee1.tar.gz
gentoo-19a8e78eab2320df5709d981a092d848df30fee1.tar.bz2
gentoo-19a8e78eab2320df5709d981a092d848df30fee1.zip
dev-python/cryptography: Enable pypy3
Diffstat (limited to 'dev-python/cryptography/cryptography-1.6.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-1.6.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/cryptography/cryptography-1.6.ebuild b/dev-python/cryptography/cryptography-1.6.ebuild
index 5fb681b19472..4c8499e776aa 100644
--- a/dev-python/cryptography/cryptography-1.6.ebuild
+++ b/dev-python/cryptography/cryptography-1.6.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -22,7 +22,7 @@ RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
$(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy{,3})
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]