summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-26 16:17:47 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-26 16:19:12 -0700
commit315d95092d7a32cfe600ef8c8632e89950c8f4aa (patch)
tree288cf29fd7bbc36105d5ef6aa00cab3f77d46192 /dev-python/css-parser
parentapp-text/kjots: Drop 5.0.2 (r0) (diff)
downloadgentoo-315d95092d7a32cfe600ef8c8632e89950c8f4aa.tar.gz
gentoo-315d95092d7a32cfe600ef8c8632e89950c8f4aa.tar.bz2
gentoo-315d95092d7a32cfe600ef8c8632e89950c8f4aa.zip
dev-python/css-parser: Update PYTHON_COMPAT
Bug: https://bugs.gentoo.org/710390 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/css-parser')
-rw-r--r--dev-python/css-parser/css-parser-1.0.4-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/css-parser/css-parser-1.0.4-r1.ebuild b/dev-python/css-parser/css-parser-1.0.4-r1.ebuild
index 6e64e14284fe..16d755705e6f 100644
--- a/dev-python/css-parser/css-parser-1.0.4-r1.ebuild
+++ b/dev-python/css-parser/css-parser-1.0.4-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -15,3 +15,9 @@ SLOT="0"
KEYWORDS="amd64 ~arm x86"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Tests fail under network-sandbox.
+RESTRICT+=" test"
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTHON}"
+}