summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-10 00:20:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-10 00:24:38 +0200
commitac9019426aef2193096c1946273a267886136080 (patch)
tree151657f7311776f97bc5ec53e5bb857bf6443b84 /dev-python/cssutils/cssutils-1.0.2-r2.ebuild
parentapp-antivirus/clamav: Stabilize 0.103.2 amd64, #780894 (diff)
downloadgentoo-ac9019426aef2193096c1946273a267886136080.tar.gz
gentoo-ac9019426aef2193096c1946273a267886136080.tar.bz2
gentoo-ac9019426aef2193096c1946273a267886136080.zip
dev-python/cssutils: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cssutils/cssutils-1.0.2-r2.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-1.0.2-r2.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2-r2.ebuild b/dev-python/cssutils/cssutils-1.0.2-r2.ebuild
deleted file mode 100644
index a62b3cba2e6a..000000000000
--- a/dev-python/cssutils/cssutils-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A CSS Cascading Style Sheets library"
-HOMEPAGE="https://pypi.org/project/cssutils/ https://cthedot.de/cssutils/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable test failing with dev-python/pyxml installed.
- if has_version dev-python/pyxml; then
- sed -e "s/test_linecol/_&/" \
- -i src/cssutils/tests/test_errorhandler.py \
- || die
- fi
-
- # requires old pbr, does it really?
- sed \
- -e '/tests_require/d' \
- -i setup.py || die
-
- # fix casing of call to Windows-1252. Remove when upstream fixes casing.
- sed -i -e 's/encutils.tryEncodings(test)/encutils.tryEncodings(test).lower()/' \
- src/cssutils/tests/test_encutils/__init__.py || die "fixing test_encutils failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
- # esetup.py test
- # exclude tests that connect to the network
- set -- nosetests \
- -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
- echo "$@"
- "$@" || die "Testing failed with ${EPYTHON}"
-}