summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-08-01 16:54:13 -0400
committerAaron Bauman <bman@gentoo.org>2020-08-01 16:55:37 -0400
commitc36f6e373a2f34541dc5dae46ea202c7d004e6bb (patch)
treeef8fd8b89e60dac24da570f2a20e8e029a47e1c1 /dev-python/ctypesgen
parentwww-apps/bugzilla: vbump 5.0.6 (diff)
downloadgentoo-c36f6e373a2f34541dc5dae46ea202c7d004e6bb.tar.gz
gentoo-c36f6e373a2f34541dc5dae46ea202c7d004e6bb.tar.bz2
gentoo-c36f6e373a2f34541dc5dae46ea202c7d004e6bb.zip
dev-python/ctypesgen: bump to 1.0.2; bump EAPI
* pkg will build fine with python3_{8,9} but tests fail Closes: https://bugs.gentoo.org/730474 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/ctypesgen')
-rw-r--r--dev-python/ctypesgen/Manifest1
-rw-r--r--dev-python/ctypesgen/ctypesgen-1.0.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ctypesgen/Manifest b/dev-python/ctypesgen/Manifest
index d0814d56c0ec..fe3c67a77500 100644
--- a/dev-python/ctypesgen/Manifest
+++ b/dev-python/ctypesgen/Manifest
@@ -1 +1,2 @@
DIST ctypesgen-0_p72.tar.bz2 85694 BLAKE2B eab6f01c7fc541f069d131abe255a51dd876e0629639cb46a8fac215da55af80746771cd15a5de4b300c58f56e4b975985953d4efe5327c8d2b29c37c166c393 SHA512 eab85c71a2f98fd03ae582899de680bd861e7e6e20841ac087520f8b844dc686ea519b0510382cedec09ff3fa1d87fcc1c79878a2eb9219d7cc092423813e2e5
+DIST ctypesgen-1.0.2.tar.gz 119413 BLAKE2B 27bc387ccbcd62cd164aef544129ead58248272251d2e2737f7fd65f22b92def3b62845a92dab4e1ba3faf030a002b4f2a67bfb0492ffb6298ddba9d7a2ba0f3 SHA512 d5168f72a04878d64b43c096f84f2a32663d481d7ac37f78d706f11aa09b68fe267af476885232a8c64be0f33dec20937e11bbfdef6231ecef1b19eae592d638
diff --git a/dev-python/ctypesgen/ctypesgen-1.0.2.ebuild b/dev-python/ctypesgen/ctypesgen-1.0.2.ebuild
new file mode 100644
index 000000000000..0ea04a163571
--- /dev/null
+++ b/dev-python/ctypesgen/ctypesgen-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg compiles fine with py3_{8,9} but tests fail
+PYTHON_COMPAT=( python3_7 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper generator for ctypes"
+HOMEPAGE="https://github.com/davidjamesca/ctypesgen"
+SRC_URI="https://github.com/davidjamesca/ctypesgen/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+python_test() {
+ "${PYTHON}" "${PN}/test/testsuite.py" || die "Test ${f} fails with ${EPYTHON}"
+}