summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-18 18:06:19 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-18 18:54:06 -0600
commit29d24fb32cfb18ac8c5bd81ab2377bcea331814e (patch)
tree5504dc6d0d25a955f8a58f9d15dd3196844c77c8 /dev-python/cursive/cursive-0.2.1.ebuild
parentdev-python/glance_store: 0.23.0 bup (diff)
downloadgentoo-29d24fb32cfb18ac8c5bd81ab2377bcea331814e.tar.gz
gentoo-29d24fb32cfb18ac8c5bd81ab2377bcea331814e.tar.bz2
gentoo-29d24fb32cfb18ac8c5bd81ab2377bcea331814e.zip
dev-python/cursive: 0.2.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/cursive/cursive-0.2.1.ebuild')
-rw-r--r--dev-python/cursive/cursive-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cursive/cursive-0.2.1.ebuild b/dev-python/cursive/cursive-0.2.1.ebuild
new file mode 100644
index 000000000000..26f122ee8bb1
--- /dev/null
+++ b/dev-python/cursive/cursive-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"