summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-12 09:58:21 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-12 10:44:18 +0100
commite6deb29f307ece97c5c0f0b044ade1c8742e3e35 (patch)
tree99b531751f10aa187390ca4d41bfbcbf8fd22215 /dev-python/curtsies/curtsies-0.1.22.ebuild
parentnet-fs/samba: Minor formatting fixes. (diff)
downloadgentoo-e6deb29f307ece97c5c0f0b044ade1c8742e3e35.tar.gz
gentoo-e6deb29f307ece97c5c0f0b044ade1c8742e3e35.tar.bz2
gentoo-e6deb29f307ece97c5c0f0b044ade1c8742e3e35.zip
dev-python/curtsies: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/curtsies/curtsies-0.1.22.ebuild')
-rw-r--r--dev-python/curtsies/curtsies-0.1.22.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.1.22.ebuild b/dev-python/curtsies/curtsies-0.1.22.ebuild
new file mode 100644
index 000000000000..de7c5bf45caf
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.1.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --verbose tests || die
+}