summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-24 20:23:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-24 20:48:34 +0100
commit81b6fe8978dcb2e345083030a2deb655cb1692f0 (patch)
tree18e7114265445632374f4e28ffe9c20d4b694df2 /dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.5.3 (diff)
downloadgentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.tar.gz
gentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.tar.bz2
gentoo-81b6fe8978dcb2e345083030a2deb655cb1692f0.zip
dev-python/cwcwidth: New package (Cython version of wcwidth)
Add the Cython alternative to dev-python/wcwidth, that uses the libc functions. It is a new dependency of dev-python/curtsies. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cwcwidth/cwcwidth-0.1.1.ebuild')
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
new file mode 100644
index 000000000000..fc41a3538ac6
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}