summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-12 05:25:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-12 06:01:21 +0200
commit84e31e667b4ee9e20d45cd403bac5220f8fb72e1 (patch)
tree27fcc8e00efea4fd1d9f1e3805308713a386a705 /dev-python/dask
parentdev-python/pytest: Bump to 6.0.2 (diff)
downloadgentoo-84e31e667b4ee9e20d45cd403bac5220f8fb72e1.tar.gz
gentoo-84e31e667b4ee9e20d45cd403bac5220f8fb72e1.tar.bz2
gentoo-84e31e667b4ee9e20d45cd403bac5220f8fb72e1.zip
dev-python/dask: Bump to 2.26.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2.26.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 50f51197d3ba..f970651892e3 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -3,3 +3,4 @@ DIST dask-2.22.0.tar.gz 2831467 BLAKE2B 641f71c868fe49a027adab11b0a84c091537bfe5
DIST dask-2.23.0.tar.gz 2840133 BLAKE2B 2fe8e4007acf2bbd8bfab889e4d912a15518318dc019573ce6deb7f3a64504608e1e27c3bd9c6766dd98a071ed075065da9beda3f2e5fef27c7bfc9918516d0a SHA512 6ce0f1471357cfa4f5c7f2e2ab31009e68d3e5de363569867d67038ae2e1a9c69552797fb232fb92deafc3b57aa040df9e60669c1856cbb53505a905c4f4b052
DIST dask-2.24.0.tar.gz 2826106 BLAKE2B fc63bf33f8441a70412e7872c696c071c5e156137fe767007a57f6d2c6a976bd29fff4db20f42c76014bbaf8b763f0a9d974ed1fc62530a3a91633ab97a1a466 SHA512 cf9a781c64eca4be84b82d026cfa1883d54ce18c93625e28c085a7bd63ac129befeded808c817e4adab790c28aa2eeca4f79c7086be683f1a7d30c6d1961c0ae
DIST dask-2.25.0.tar.gz 2842089 BLAKE2B 048a116a60dd98c7c1f3800426af13c2d8d116772a6b3133823b9a78ae6fcd34ab32dbfb9ae8db9eb6c948bce381e5d6e91caaab78203ae56159493ed7689038 SHA512 0d6e8e8c1efbaa4dc77e1a505e5c2df45eefc43868ce923ec674c5f768f12beb30e06c8712f621e44a826fc11f86fd50e60f0f6a78e261d74273f73b49503301
+DIST dask-2.26.0.tar.gz 2852574 BLAKE2B 66abba9ef32bee11249557e38eee7e60d2988f098904bd867e5e9ad110d735c1a3b3f10829c58fdca5400f078fc569822e7e73f0e9c6894dbbfa41b46d521f61 SHA512 07daf541570e9e30fcb97f607b9629761d14de58fcb4b89fd01f9688690af1b55b80e3e62eefc54942d47da5fcb9d3c4aa6bca0b76f4bf60e664054515e18fcb
diff --git a/dev-python/dask/dask-2.26.0.ebuild b/dev-python/dask/dask-2.26.0.ebuild
new file mode 100644
index 000000000000..eb47b5d4660c
--- /dev/null
+++ b/dev-python/dask/dask-2.26.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.4[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/s3fs-0.0.8[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -m "not network" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests failed with ${EPYTHON}"
+}