summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 08:04:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 09:27:43 +0200
commit86bf764cbd2aa936002678f917b6a8a16bb56f62 (patch)
tree9915c92eef350b40de87f890254e1e50757c1d8d /dev-python/dask
parentdev-python/arrow: Bump to 0.17.0 (diff)
downloadgentoo-86bf764cbd2aa936002678f917b6a8a16bb56f62.tar.gz
gentoo-86bf764cbd2aa936002678f917b6a8a16bb56f62.tar.bz2
gentoo-86bf764cbd2aa936002678f917b6a8a16bb56f62.zip
dev-python/dask: Bump to 2.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2.30.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 36b1274a546b..8542b7ae2e33 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -4,3 +4,4 @@ DIST dask-2.26.0.tar.gz 2852574 BLAKE2B 66abba9ef32bee11249557e38eee7e60d2988f09
DIST dask-2.27.0.tar.gz 2852785 BLAKE2B 7be6704269f21891ed6a3289ee16827a1494591f7024d158e88001d4e10f263409e33f9c0e14e21ec8fed3d6798a6b011e8cfffec4659d6b07d2c4b31355c6a6 SHA512 afa7454e208cdfd482ff971aeda8db6364408661c1230c7e33fc05e63dfbe3e26e899415af0e4625a642dab15a29fce9c432d24d21e8a3bf7760f6ae304fc371
DIST dask-2.28.0.tar.gz 2858331 BLAKE2B 9adbae83559a1a5a218aacb575ec6e4007cc0bcebf4f2ddac4a2bc23de2be74887ee41ff341c05e0e1612a42d4b3bd5d7ca072b58f7cbc9fa516d8c45f7f0ae2 SHA512 f36b1cc843b0ef7efdae0af1ffdc91ac251cfcbd63160379f479f55005b93e111818f782db2a7ecf8e6bbd63ea48661a178d1c2ca74473a4d477025bb955cbcd
DIST dask-2.29.0.tar.gz 2857095 BLAKE2B 463d3e6edfa868b18be1c6f9919d07ded3d05036c2a90cd8845c1102cef67320f5b400c00188d5188ba393a0bd36fcfd234db75e6815f773f3a43abdba6875e0 SHA512 013cbfd31c5f59fdf56b0700ce2c0cd63dcaf653fdf2ddd8f083af84f13a38a1f09f6ce63fb7aa8cdc0786314b8a36144a8d186fb0d8af8ee8e81358bf4e1ab7
+DIST dask-2.30.0.tar.gz 2858866 BLAKE2B ea5e1e50f9bef2ca81765ee1228ea661ea01355f4c2a495e916388cb757dc089c519eb83372abc2ece16c8ec27e3b7f7fe56a302eddfdc6c0e79247db9c1b65e SHA512 d410fcfc7e30f510bc42e9547bac912609420919489e161408d436fb26c3998eba6bfc9e4845d90b3e8589ecc317ee4bf141e2740108840f2e5a420eb20655ef
diff --git a/dev-python/dask/dask-2.30.0.ebuild b/dev-python/dask/dask-2.30.0.ebuild
new file mode 100644
index 000000000000..f0f21e67dc47
--- /dev/null
+++ b/dev-python/dask/dask-2.30.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.4[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/s3fs-0.0.8[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -m "not network" ||
+ die "Tests failed with ${EPYTHON}"
+}