summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 09:05:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 09:21:20 +0200
commit9820601b79b65e020e7975dfb783430c8f5ad4ee (patch)
tree8941c9e9bfc70851562f121eaf9543c58d8bcd59 /dev-python/dask
parentdev-python/xlsxwriter: Bump to 1.3.4 (diff)
downloadgentoo-9820601b79b65e020e7975dfb783430c8f5ad4ee.tar.gz
gentoo-9820601b79b65e020e7975dfb783430c8f5ad4ee.tar.bz2
gentoo-9820601b79b65e020e7975dfb783430c8f5ad4ee.zip
dev-python/dask: Bump to 2.27.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2.27.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 1be6d2408b17..0dee5d8601ec 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,4 @@
DIST dask-2.23.0.tar.gz 2840133 BLAKE2B 2fe8e4007acf2bbd8bfab889e4d912a15518318dc019573ce6deb7f3a64504608e1e27c3bd9c6766dd98a071ed075065da9beda3f2e5fef27c7bfc9918516d0a SHA512 6ce0f1471357cfa4f5c7f2e2ab31009e68d3e5de363569867d67038ae2e1a9c69552797fb232fb92deafc3b57aa040df9e60669c1856cbb53505a905c4f4b052
DIST dask-2.25.0.tar.gz 2842089 BLAKE2B 048a116a60dd98c7c1f3800426af13c2d8d116772a6b3133823b9a78ae6fcd34ab32dbfb9ae8db9eb6c948bce381e5d6e91caaab78203ae56159493ed7689038 SHA512 0d6e8e8c1efbaa4dc77e1a505e5c2df45eefc43868ce923ec674c5f768f12beb30e06c8712f621e44a826fc11f86fd50e60f0f6a78e261d74273f73b49503301
DIST dask-2.26.0.tar.gz 2852574 BLAKE2B 66abba9ef32bee11249557e38eee7e60d2988f098904bd867e5e9ad110d735c1a3b3f10829c58fdca5400f078fc569822e7e73f0e9c6894dbbfa41b46d521f61 SHA512 07daf541570e9e30fcb97f607b9629761d14de58fcb4b89fd01f9688690af1b55b80e3e62eefc54942d47da5fcb9d3c4aa6bca0b76f4bf60e664054515e18fcb
+DIST dask-2.27.0.tar.gz 2852785 BLAKE2B 7be6704269f21891ed6a3289ee16827a1494591f7024d158e88001d4e10f263409e33f9c0e14e21ec8fed3d6798a6b011e8cfffec4659d6b07d2c4b31355c6a6 SHA512 afa7454e208cdfd482ff971aeda8db6364408661c1230c7e33fc05e63dfbe3e26e899415af0e4625a642dab15a29fce9c432d24d21e8a3bf7760f6ae304fc371
diff --git a/dev-python/dask/dask-2.27.0.ebuild b/dev-python/dask/dask-2.27.0.ebuild
new file mode 100644
index 000000000000..e188a716d44c
--- /dev/null
+++ b/dev-python/dask/dask-2.27.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.4[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/s3fs-0.0.8[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -m "not network" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests failed with ${EPYTHON}"
+}