summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-01 08:48:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-01 12:09:41 +0200
commitf2f7ad28e8870825582f6d0fbae49c33b6a641cb (patch)
tree18daafdc482c116b604d56e4a21f6239439fbb0a /dev-python/dask
parentdev-python/yarl: Bump to 1.5.1 (diff)
downloadgentoo-f2f7ad28e8870825582f6d0fbae49c33b6a641cb.tar.gz
gentoo-f2f7ad28e8870825582f6d0fbae49c33b6a641cb.tar.bz2
gentoo-f2f7ad28e8870825582f6d0fbae49c33b6a641cb.zip
dev-python/dask: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2.22.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 65b2f7241fd2..497e326a6d37 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1 +1,2 @@
DIST dask-1.2.0.tar.gz 2381831 BLAKE2B 88d48b9bcd4444dfe066c8049eae2a8b65e6ae1a7e4f4ff89697c254efc365091a61b298333b0f8d660cc9f760d3960a355beafde2555dfd912606dbe4a49db1 SHA512 c00886768b331f48ac9627f81c39368afbb4f1083ee9f7e3ebbe64352cc48c3c580fccef8d5466592f5bf772f873bef2ac084a972d30e7c1b4d1028e1d456059
+DIST dask-2.22.0.tar.gz 2831467 BLAKE2B 641f71c868fe49a027adab11b0a84c091537bfe56a786bbb00215ade5ba5fa7687176f70f12802b06bbcaf00db76f0c97eaa5b87cb65fc28bbe3e37c8b55f2a6 SHA512 90d6391a8dfc36788e819bf09f4ea65a89f37b14d0755fe4ade9179e5d3edd6dada30d5c08ad730f4ac9e08a0cc64a354933f52b92eb13fb8e60093dbcf28567
diff --git a/dev-python/dask/dask-2.22.0.ebuild b/dev-python/dask/dask-2.22.0.ebuild
new file mode 100644
index 000000000000..01da771a26e1
--- /dev/null
+++ b/dev-python/dask/dask-2.22.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="distributed"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.4[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+ distributed? (
+ >=dev-python/distributed-2.0[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/s3fs-0.0.8[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # don't die on warnings or xpass
+ sed -i -e '/error:::/d' -e '/xfail_strict/d' setup.cfg || die
+ # flaky
+ sed -e 's:test_time_rolling_methods:_&:' \
+ -i dask/dataframe/tests/test_rolling.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv -m "not network" -n auto ||
+ die "Tests failed with ${EPYTHON}"
+}