summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-26 20:34:07 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-26 20:52:09 +0100
commit009a8a7b6837f7d6bc3fbe83cd5b23e307103e0b (patch)
treed5f2a1ad6c4d4419839ede92d8490cae03a86484 /dev-python/datashape/datashape-0.5.0.ebuild
parentadding arm64 keyword to C based openstack packages (diff)
downloadgentoo-009a8a7b6837f7d6bc3fbe83cd5b23e307103e0b.tar.gz
gentoo-009a8a7b6837f7d6bc3fbe83cd5b23e307103e0b.tar.bz2
gentoo-009a8a7b6837f7d6bc3fbe83cd5b23e307103e0b.zip
dev-python/datashape: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/datashape/datashape-0.5.0.ebuild')
-rw-r--r--dev-python/datashape/datashape-0.5.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/datashape/datashape-0.5.0.ebuild b/dev-python/datashape/datashape-0.5.0.ebuild
new file mode 100644
index 000000000000..9a7769308fcd
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}