summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 21:57:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 21:57:44 -0500
commit73262d81baa9a4868569894520cf92374909abf3 (patch)
tree09a5be6b2ef838f37745249f24a8c61050be7295 /dev-python/debtcollector
parentdev-python/doc8: more pythons (diff)
downloadgentoo-73262d81baa9a4868569894520cf92374909abf3.tar.gz
gentoo-73262d81baa9a4868569894520cf92374909abf3.tar.bz2
gentoo-73262d81baa9a4868569894520cf92374909abf3.zip
dev-python/debtcollector: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-1.3.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 29fb55987b4d..f36a7553f6eb 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1,2 +1,3 @@
DIST debtcollector-0.10.0.tar.gz 20669 SHA256 8cc22cf2223af7789692ef0b1cb5c0c3a00da7d6e34cbfce125a956cb4d2f21e SHA512 a521a4dd5229384a500e973fa504be75c9019abd00cd4012118a566a1b4d95ecc10d616de29e0c16953a69fe7cdd219b44afb9463c59a6220c49d4a3dd12f896 WHIRLPOOL 2ffac565e27d411321a4c8c662e78bd0774158d9be0f77f8f7baa049fd62e52cd1b8a3a552f0f993e7e4c0b9325b0be3446580e602e4524e95f7d1e58361f388
DIST debtcollector-0.7.0.tar.gz 17151 SHA256 03ef06604e666a9f4a1506ffcfa887068bdb9f16e33657f9211a7b4e8bc753ea SHA512 684bea62b17843717c6aa19f36e538bd62bfe101693394eb66d6d6f408f32a0c9e458dee8c81324f4503fab952b73654f2eca24c51ef67594c51657fcdca9dad WHIRLPOOL 32cb704719ae3ea00f3d5e4e1df225604e226c5c4882afcf136fdfe035c367b334f1409c35b079214f8ab8b04608ef8a1f648a38632fc9fef9a8f312ce76d3c0
+DIST debtcollector-1.3.0.tar.gz 21853 SHA256 9a65cf09239eab75b961ef609b3176ed2487bedcfa0a465331661824e1c8db8f SHA512 b53ef131599fb04abb9f11e8abe3dc8447a595695bab505be642c03925e0da625e6a10944ec10863526645080ed3ce43b9a5138a1f7ba91511ade6daf42d018a WHIRLPOOL 04c6ee34a48955a86535c3161005417f5c5dfca9152e092c3856d61a4707f6249245398006d0da0c31ffa7103ab69a566bf84d7321b70362d59f359b5225622f
diff --git a/dev-python/debtcollector/debtcollector-1.3.0.ebuild b/dev-python/debtcollector/debtcollector-1.3.0.ebuild
new file mode 100644
index 000000000000..7d7708ca229a
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-1.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python deprecation patterns and strategies that collect technical debt"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ dev-python/doc8[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || di
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}