summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 09:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:41:29 +0200
commit782d86bd2dba251e5793f15c0de7166e50afdace (patch)
treedb4ae6f0cf412f7b98ca6da4f80720bb3df63b7a /dev-python/debugpy
parentdev-python/cvxopt: Remove old (diff)
downloadgentoo-782d86bd2dba251e5793f15c0de7166e50afdace.tar.gz
gentoo-782d86bd2dba251e5793f15c0de7166e50afdace.tar.bz2
gentoo-782d86bd2dba251e5793f15c0de7166e50afdace.zip
dev-python/debugpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest2
-rw-r--r--dev-python/debugpy/debugpy-1.4.1.ebuild39
-rw-r--r--dev-python/debugpy/debugpy-1.4.2.ebuild44
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index 8a2f2e5b390c..d9567ae5c0a3 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1,3 +1 @@
-DIST debugpy-1.4.1.tar.gz 6687670 BLAKE2B c7761f354700d366d49365b0294ba1f07f357283c7527fc961c702bf99d808835741a899909e37092026c81ff19f6d96ef09c06512c8315ccad158b6e8e47697 SHA512 aef7779cb3a1af76b5cd3d6e8c7e0b78ffe08d1ebe25cf617ca3eb00966d5b3920358809c018f5f1f9eb56b913211134acfdba7d4c0d0174e4d6cfdae058d5f5
-DIST debugpy-1.4.2.tar.gz 6673987 BLAKE2B c61d09bc036f3a12e343be3d81b2e834bd69d33df80a6b9e4111d11a2eaea221feea3ac093ca06ad1a840dcab7d53d7b321276c4103420f34adac7a4a4ac8141 SHA512 7c0908ab9202cebb020ca72c558f3c1abc28b44fb968cce4387750f18e67198ad52dd6743061888610ed733e0f7334f986c2655ec7b0a2631acc4919cd9e6c20
DIST debugpy-1.5.0.gh.tar.gz 6676475 BLAKE2B a8aa0afe7b76beb6ba539e23558d6a0c8babfd55de9a4a0bc9aabbec8a2318e600df62b063a8d674d9402e35fd595b030efca570b4a67ec82dadb98875261e13 SHA512 b5ca216aede744a9b1e067056601470e78b8af1fabb181dc0bf6e87bc166cc8d6cad24f5695986686cac69f8ce41246bb0f074078ef3750f6e65b4d8fe55e869
diff --git a/dev-python/debugpy/debugpy-1.4.1.ebuild b/dev-python/debugpy/debugpy-1.4.1.ebuild
deleted file mode 100644
index 9e2e9b284cd9..000000000000
--- a/dev-python/debugpy/debugpy-1.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="https://github.com/microsoft/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc"
-
-# There is not enough time in the universe for this test suite
-RESTRICT="test"
-
-# These files are included pre-built in the sources
-# TODO: Investigate what this is and if/how we can compile this properly
-QA_PREBUILT="
- /usr/lib/python*/site-packages/${PN}/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
-"
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -i \
- -e 's/-n8//g' \
- -e '/timeout/d' \
- pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-distutils_enable_tests pytest
diff --git a/dev-python/debugpy/debugpy-1.4.2.ebuild b/dev-python/debugpy/debugpy-1.4.2.ebuild
deleted file mode 100644
index cb5a07791515..000000000000
--- a/dev-python/debugpy/debugpy-1.4.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="https://github.com/microsoft/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-# There is not enough time in the universe for this test suite
-RESTRICT="test"
-
-BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
-
-RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-unbundle-pydevd.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -i \
- -e 's/-n8//g' \
- -e '/timeout/d' \
- pytest.ini || die
-
- # Unbundle dev-python/pydevd
- rm -r src/debugpy/_vendored || die
-
- distutils-r1_python_prepare_all
-}