summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/decorator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/Manifest3
-rw-r--r--dev-python/decorator/decorator-3.4.0-r1.ebuild31
-rw-r--r--dev-python/decorator/decorator-3.4.2.ebuild28
-rw-r--r--dev-python/decorator/decorator-4.0.2.ebuild30
-rw-r--r--dev-python/decorator/files/decorator-3.4.0-test-failure-exit.patch35
-rw-r--r--dev-python/decorator/metadata.xml12
6 files changed, 139 insertions, 0 deletions
diff --git a/dev-python/decorator/Manifest b/dev-python/decorator/Manifest
new file mode 100644
index 000000000000..d1715c3ce033
--- /dev/null
+++ b/dev-python/decorator/Manifest
@@ -0,0 +1,3 @@
+DIST decorator-3.4.0.tar.gz 30333 SHA256 c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783 SHA512 94ae8ff3bf694b72ad85a04d02ed9b58c42d50341fbc7307a12fc5abcb8042d8f67df80b53e63afd4b692c52fbefec83b80b591cba036deee21e281a5e8ff249 WHIRLPOOL 05b1c59e23ca3ca38cf06a08ae7ef253779c18050445f37a7f926e69456979ab539966e1821a0bd97b63aeef343a89a681a01d0da54182992cdc769c1cdda5b4
+DIST decorator-3.4.2.tar.gz 6115 SHA256 7320002ce61dea6aa24adc945d9d7831b3669553158905cdd12f5d0027b54b44 SHA512 48e5c65ba4243310267e4a75660a55091d5d354e35f31c3c37d886bdf2f8bf915b54d829b9a0a8affe35920e1c981c41a06bcac0eaa8930b47a6ed1c68a71566 WHIRLPOOL 51b7afd6e91967783ffccab73b9a26fb53e103da5e9116621268828874bd6ace55c37f6ba5881bbdfd3593d017b5eaa42c9017c0cbaa88360af69a2368b7eef7
+DIST decorator-4.0.2.tar.gz 64850 SHA256 1a089279d5de2471c47624d4463f2e5b3fc6a2cf65045c39bf714fc461a25206 SHA512 9f135c9c624557a90619e46002f12d54f8c53045420f524bbc52dee0b488268501467b207ea8f4445a8aa7d119af3e615cd76cbc25c1d1335d3bb581a1045ab3 WHIRLPOOL 1a4a31fe67d4cdfc58cb5486f83ee059a9211af5c5e48d57c9b22a24e08e5659a2e8b4519ecaba68fa603ef6e5a0756f69ee10fbe173d07ffe23204b579f2f18
diff --git a/dev-python/decorator/decorator-3.4.0-r1.ebuild b/dev-python/decorator/decorator-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..f007a316aed6
--- /dev/null
+++ b/dev-python/decorator/decorator-3.4.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator http://code.google.com/p/micheles/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-failure-exit.patch
+)
+
+python_test() {
+ local t=documentation.py
+ [[ ${EPYTHON} == python3* ]] && t=documentation3.py
+
+ "${PYTHON}" ${t} || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/decorator/decorator-3.4.2.ebuild b/dev-python/decorator/decorator-3.4.2.ebuild
new file mode 100644
index 000000000000..81a946181b75
--- /dev/null
+++ b/dev-python/decorator/decorator-3.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator http://code.google.com/p/micheles/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+# This release is missing no less than 8 files
+
+#python_test() {
+# local t=documentation.py
+# python_is_python3 && t=documentation3.py
+#
+# "${PYTHON}" ${t} || die "Tests fail with ${EPYTHON}"
+#}
diff --git a/dev-python/decorator/decorator-4.0.2.ebuild b/dev-python/decorator/decorator-4.0.2.ebuild
new file mode 100644
index 000000000000..3fafdcc465a2
--- /dev/null
+++ b/dev-python/decorator/decorator-4.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator http://code.google.com/p/micheles/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/README.rst )
+
+python_test() {
+ "${PYTHON}" src/tests/test.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dodoc documentation.pdf
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/decorator/files/decorator-3.4.0-test-failure-exit.patch b/dev-python/decorator/files/decorator-3.4.0-test-failure-exit.patch
new file mode 100644
index 000000000000..4126e2bdced0
--- /dev/null
+++ b/dev-python/decorator/files/decorator-3.4.0-test-failure-exit.patch
@@ -0,0 +1,35 @@
+From fb1fc865000c92fc431a04d54116001c35ec0cdd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Fri, 21 Dec 2012 00:29:53 +0100
+Subject: [PATCH] Exit with failure when doctests fail.
+
+---
+ documentation.py | 3 ++-
+ documentation3.py | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/documentation.py b/documentation.py
+index 3d5a5c0..0ddd681 100644
+--- a/documentation.py
++++ b/documentation.py
+@@ -1131,4 +1131,5 @@ def hello(user):
+ print('hello %s' % user)
+
+ if __name__ == '__main__':
+- import doctest; doctest.testmod()
++ import doctest
++ sys.exit(0 if doctest.testmod()[0] == 0 else 1)
+diff --git a/documentation3.py b/documentation3.py
+index bd86cc6..4162d56 100644
+--- a/documentation3.py
++++ b/documentation3.py
+@@ -1167,4 +1167,5 @@ def hello(user):
+ print('hello %s' % user)
+
+ if __name__ == '__main__':
+- import doctest; doctest.testmod()
++ import doctest
++ sys.exit(0 if doctest.testmod()[0] == 0 else 1)
+--
+1.8.0.2
+
diff --git a/dev-python/decorator/metadata.xml b/dev-python/decorator/metadata.xml
new file mode 100644
index 000000000000..cc991ffb9094
--- /dev/null
+++ b/dev-python/decorator/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">The aim of the decorator python module is to simplify the usage of
+ decorators for the average programmer and to popularize
+ decorators usage giving examples of useful decorators, such as
+ memoize, tracing, redirecting_stdout, locked, etc.</longdescription>
+ <upstream>
+ <remote-id type="pypi">decorator</remote-id>
+ </upstream>
+</pkgmetadata>