summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/decoratortools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/decoratortools')
-rw-r--r--dev-python/decoratortools/Manifest1
-rw-r--r--dev-python/decoratortools/decoratortools-1.8-r1.ebuild35
-rw-r--r--dev-python/decoratortools/metadata.xml9
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/decoratortools/Manifest b/dev-python/decoratortools/Manifest
new file mode 100644
index 000000000000..a7b4969ad996
--- /dev/null
+++ b/dev-python/decoratortools/Manifest
@@ -0,0 +1 @@
+DIST DecoratorTools-1.8.zip 29566 SHA256 da73f03a9fab80a205c8febcecee83f8a989eab8ce81affd7989210e4a3d9ea8 SHA512 b107b61d76c1c41ebe4f663d42fff3ecf184364fa46c234a8ad9df0d626bdd113c7527c6e1d97fc2d38c0fc76ff43dbe0190fc1297240c44d9ba490b11f6fa51 WHIRLPOOL efc61d822b3c8862fa2a927284e01b7c7e5d739afc576bc2bcca03f504b65d33119ba525de25f42d951291fc55279061998c8b9bca876185afdd88a2bbff42fb
diff --git a/dev-python/decoratortools/decoratortools-1.8-r1.ebuild b/dev-python/decoratortools/decoratortools-1.8-r1.ebuild
new file mode 100644
index 000000000000..af03a1de35ef
--- /dev/null
+++ b/dev-python/decoratortools/decoratortools-1.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="DecoratorTools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class, function, and metaclass decorators"
+HOMEPAGE="http://pypi.python.org/pypi/DecoratorTools"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="|| ( PSF-2 ZPL )"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable tests broken with named tuples.
+ sed -e "s/additional_tests/_&/" -i test_decorators.py || die "sed failed"
+}
+
+python_test() {
+ esetup.py test && einfo "Tests passed under ${EPYTHON}" || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/decoratortools/metadata.xml b/dev-python/decoratortools/metadata.xml
new file mode 100644
index 000000000000..56f3768c3602
--- /dev/null
+++ b/dev-python/decoratortools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">Use class and function decorators - even in Python 2.3 - now with source debugging for generated code.</longdescription>
+ <upstream>
+ <remote-id type="pypi">DecoratorTools</remote-id>
+ </upstream>
+</pkgmetadata>