summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 13:40:39 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 16:22:43 +0100
commit08e8d3a7ae49455f8d965da3780057a9131d57ac (patch)
treecf0637ea98b5a0be2f84901d3f5ed780b6f81cce /dev-python/demjson/demjson-2.2.4.ebuild
parentdev-python/ddt: Bump (diff)
downloadgentoo-08e8d3a7ae49455f8d965da3780057a9131d57ac.tar.gz
gentoo-08e8d3a7ae49455f8d965da3780057a9131d57ac.tar.bz2
gentoo-08e8d3a7ae49455f8d965da3780057a9131d57ac.zip
dev-python/demjson: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/demjson/demjson-2.2.4.ebuild')
-rw-r--r--dev-python/demjson/demjson-2.2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/demjson/demjson-2.2.4.ebuild b/dev-python/demjson/demjson-2.2.4.ebuild
new file mode 100644
index 000000000000..f2ed84f4162f
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ https://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}