summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-19 04:21:26 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-19 04:32:52 +0200
commitc38701a1795f80656144f84209311b927e579ba8 (patch)
treedce6e1af3344cf7ed8ab5de1598a9efab6ec09ee /dev-python/deprecated
parentdev-python/kconfiglib: fix build with py2 (diff)
downloadgentoo-c38701a1795f80656144f84209311b927e579ba8.tar.gz
gentoo-c38701a1795f80656144f84209311b927e579ba8.tar.bz2
gentoo-c38701a1795f80656144f84209311b927e579ba8.zip
dev-python/deprecated: Bump to 1.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecated')
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index 73924199cbe7..238f85ebe201 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1 +1,2 @@
DIST deprecated-1.2.5.gh.tar.gz 5038752 BLAKE2B 82ceadca4ccef4309b2a7d493620cc8a4dd9160ab7449a3019c9e9bc3a99e8016b6125d4165b71813d9543b7629d55372affdbd14ad2c71d101061595bdb677c SHA512 3a16b5d4f2475788ce919c327b668bb8852dab88adfa959826c9b68ccbfba3207a1c60ca164edacde8a756bd3895225af944a51eebde1230a93a973145231234
+DIST deprecated-1.2.6.gh.tar.gz 5043633 BLAKE2B cc72838dc772db62ca75637268d09cbab4c9acb84b42bd1d2d76397d43b81781cfcef075a9a6e6ca2ab55eda19acae95cdfbdd820c1363e7ea4841fb1cb61b7b SHA512 fcef322c6d9c317081dae365d469d4b26b0d23d8290e7aa0ca18592fb098ae7f535cb5e898cc81e5c734e7e211c847cdd9d5430c1999a4b9612f30934243ee9e
diff --git a/dev-python/deprecated/deprecated-1.2.6.ebuild b/dev-python/deprecated/deprecated-1.2.6.ebuild
new file mode 100644
index 000000000000..4f502db5e1b9
--- /dev/null
+++ b/dev-python/deprecated/deprecated-1.2.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python @deprecated decorator to deprecate old API"
+HOMEPAGE="https://github.com/tantale/deprecated"
+SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}