summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 13:05:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 13:05:29 +0200
commitc29bbd37d9ef84c0f9be4ca30912be5973554322 (patch)
tree6dc3e65acd66a5f3c5636c7cf330ef46b6b86485 /dev-python/deprecation
parentdev-embedded/esptool: Remove incorrect unittest2 dep (diff)
downloadgentoo-c29bbd37d9ef84c0f9be4ca30912be5973554322.tar.gz
gentoo-c29bbd37d9ef84c0f9be4ca30912be5973554322.tar.bz2
gentoo-c29bbd37d9ef84c0f9be4ca30912be5973554322.zip
dev-python/deprecation: Eliminate unittest2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deprecation')
-rw-r--r--dev-python/deprecation/deprecation-2.1.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/deprecation/deprecation-2.1.0.ebuild b/dev-python/deprecation/deprecation-2.1.0.ebuild
index 435613b78604..beaa31f1df71 100644
--- a/dev-python/deprecation/deprecation-2.1.0.ebuild
+++ b/dev-python/deprecation/deprecation-2.1.0.ebuild
@@ -16,11 +16,11 @@ SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
RDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
-"
distutils_enable_sphinx docs
distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e 's:unittest2:unittest:' tests/test_deprecation.py || die
+ distutils-r1_src_prepare
+}