summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-02 08:48:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-02 10:48:51 +0100
commit6af931ab308d03b137fc6e6e01e51a2be3382c7f (patch)
tree285dbdc5bcabbd461fb1a226b0eb9fb377b8e205 /dev-python/dill
parentdev-python/phonenumbers: Bump to 8.12.12 (diff)
downloadgentoo-6af931ab308d03b137fc6e6e01e51a2be3382c7f.tar.gz
gentoo-6af931ab308d03b137fc6e6e01e51a2be3382c7f.tar.bz2
gentoo-6af931ab308d03b137fc6e6e01e51a2be3382c7f.zip
dev-python/dill: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 8e822f26c21a..8a6cf96ba1c9 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1 +1,2 @@
DIST dill-0.3.2.gh.tar.gz 148972 BLAKE2B a807350a2d2bb84e705d20c9c60d47834b41863b862a5d347ebc32273c1b9479c568cd3018126adb1cd052bb00f50e8424f7118b37524329458150b9a3e59e3d SHA512 74a0c01dd7c0126c7de21a3b3660e51486fec17f64f23b8e7f23b70243209908573fef8851f6eda53868e89ef1a8a5e351a3ef81dd9cb3e122a2dba33a86bbe1
+DIST dill-0.3.3.gh.tar.gz 149103 BLAKE2B b08830ad1eb47ceb29c6be6ae88ab38338d9a8a325188bc3890b71c7f393792988da4962819f9b82bf7ad9ebd668c96989ef8c55072a2c82483660c4ec01d072 SHA512 bb514c37902412380d99f38293d5cb9d3d6a6643a34e59e6e889c89d845f9b83e9fa3fa9f0a75218575aa56670f287144f2b00abc8359b5fc6cb450351b43b68
diff --git a/dev-python/dill/dill-0.3.3.ebuild b/dev-python/dill/dill-0.3.3.ebuild
new file mode 100644
index 000000000000..32554341e099
--- /dev/null
+++ b/dev-python/dill/dill-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}