summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-29 08:07:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-29 08:07:17 +0200
commitf4e64ab72491bef304717e5f20480bc11cf4cfaa (patch)
treeca6df8ac681cd7f22e0fffbbd430814a3a7c3978 /dev-python/dill
parentdev-db/sqlite: Stabilize 3.29.0 on amd64/x86. (diff)
downloadgentoo-f4e64ab72491bef304717e5f20480bc11cf4cfaa.tar.gz
gentoo-f4e64ab72491bef304717e5f20480bc11cf4cfaa.tar.bz2
gentoo-f4e64ab72491bef304717e5f20480bc11cf4cfaa.zip
dev-python/dill: Bump to 0.3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 01a423bf8057..62fd9439c6ea 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,2 +1,3 @@
DIST dill-0.2.5.tgz 60572 BLAKE2B 43877e36cb62406b486f5619a54db0a4983f70b0a1712e39bcd77aa892fd17dc9ea774b85faa48441beaf993296a877249ff321fd0977a1317eeb25d0b020d80 SHA512 94942a736b4c2e1558eb9475f9bafe3a24f88a976abf9880beec386497a2bc769cb9be6bbfd2baac006c92578c372f5dfcfa165c5649876ea5076a3b207de6fc
DIST dill-0.3.0.tar.gz 151375 BLAKE2B 11f22f18c5491633a2a3136d6993c59a1078d478f2e45d40e5a71fd9929527f4db98fe261d406c2cceb0cbafa277f620a17068123c73d85a44dc2252be138845 SHA512 d3e36716ec264fab2532264e82dedf2a0923ed11f2517b3df6e5576159d5701f336125e7967a37f4c80c37f60abf584b9f7cd4225ed68f942dca7af500c091cf
+DIST dill-0.3.1.1.tar.gz 151986 BLAKE2B 71b364730805974117cb00965a2276aa240b6265f2a98ae8e70ca2f9d8bf7a4b801fac083f2395932fdc016de3f068fb46091f296910ce96725bc982e774a40a SHA512 e61610451972522316d7ed6bc8287e38521fcd2e6736b43200ae498f24596994caec92313be1da71cf1b536fbbe01505673fc8018bfcbaf7705147a294565ab9
diff --git a/dev-python/dill/dill-0.3.1.1.ebuild b/dev-python/dill/dill-0.3.1.1.ebuild
new file mode 100644
index 000000000000..2df94b7bb42e
--- /dev/null
+++ b/dev-python/dill/dill-0.3.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of python (almost)"
+HOMEPAGE="https://pypi.org/project/dill/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}