summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-05 18:15:18 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-05 18:50:37 +0200
commit1d06fadc793b9eebaf40c4c004912a40b93e93b0 (patch)
tree92841f2a3e116c22b9c8d848c9cdbb53d2cdfbc6 /dev-python/discogs-client/discogs-client-9999.ebuild
parentdev-python/discogs-client: add 2.3.13, ebuild cleanup (diff)
downloadgentoo-1d06fadc793b9eebaf40c4c004912a40b93e93b0.tar.gz
gentoo-1d06fadc793b9eebaf40c4c004912a40b93e93b0.tar.bz2
gentoo-1d06fadc793b9eebaf40c4c004912a40b93e93b0.zip
dev-python/discogs-client: sync live version
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client/discogs-client-9999.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/discogs-client/discogs-client-9999.ebuild b/dev-python/discogs-client/discogs-client-9999.ebuild
index 36b9175dec97..2ca0f4090ab6 100644
--- a/dev-python/discogs-client/discogs-client-9999.ebuild
+++ b/dev-python/discogs-client/discogs-client-9999.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-
inherit distutils-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
inherit git-r3
else
- MY_PN='python3-discogs-client'
- MY_P=${MY_PN}-${PV}
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/python3-${P}"
fi
DESCRIPTION="Continuation of the official Python API client for Discogs"
-HOMEPAGE="https://github.com/joalla/discogs_client https://pypi.org/project/python3-discogs-client/"
+HOMEPAGE="https://github.com/joalla/discogs_client
+ https://pypi.org/project/python3-discogs-client/"
LICENSE="BSD-2"
SLOT="0"
@@ -30,4 +29,4 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
-distutils_enable_tests nose
+distutils_enable_tests unittest