summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-17 22:32:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-17 22:32:52 +0300
commit5bd700bd859591f728481ddac7aef14c5ac0fdbf (patch)
tree1eea54c3d25339933c3a6ea2f970864cdebbdad2 /dev-python/distlib
parentdev-python/sphinx-aiohttp-theme: drop 0.1.6 (diff)
downloadgentoo-5bd700bd859591f728481ddac7aef14c5ac0fdbf.tar.gz
gentoo-5bd700bd859591f728481ddac7aef14c5ac0fdbf.tar.bz2
gentoo-5bd700bd859591f728481ddac7aef14c5ac0fdbf.zip
dev-python/distlib: drop 0.3.4-r2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/distlib')
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.4-r2.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
index 294bf571103f..f445a29c8249 100644
--- a/dev-python/distlib/Manifest
+++ b/dev-python/distlib/Manifest
@@ -1,2 +1 @@
-DIST distlib-0.3.4.tar.bz2 1169083 BLAKE2B f1b5e5ca7d0155d204db177d9844cdff4d593be3d927bd5f9e8ad07065b52383527d3990b66c5868bb8377703d031958c5c88a9daf4f0b238903ddbea3ef6cf0 SHA512 24f8d6f5012c881ffa6bbdae7887ee5a7608ac36a83e2a96cb8a337d1ab6c896a4078028d0383165ff44be6b735aa31f7d199845d89899813be74ed00e1680e8
DIST distlib-0.3.5.gh.tar.gz 1233989 BLAKE2B 616666e835aa201ceeeb423452a25adafab67dc20f99496b711e3ca6d4916f4e1dd39e444b1c8824e90559e898fc0588cd58d2d5be07af172d6b6ed3f3c7fe4c SHA512 927861d2e11785d8419c3125784f21ee052883c03d91d8893d2c77b47739e45cbca39e5d90446e906c71744bd57274192b28af86def239a16caeae4d3887d5a6
diff --git a/dev-python/distlib/distlib-0.3.4-r2.ebuild b/dev-python/distlib/distlib-0.3.4-r2.ebuild
deleted file mode 100644
index 60f51ce70857..000000000000
--- a/dev-python/distlib/distlib-0.3.4-r2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Low-level components of distutils2/packaging"
-HOMEPAGE="
- https://pypi.org/project/distlib/
- https://bitbucket.org/pypa/distlib/
-"
-# pypi has zip only :-(
-SRC_URI="
- https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2
-"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pypiserver is called as external executable
-# openpyxl installs invalid metadata that breaks distlib
-BDEPEND="
- test? (
- dev-python/pypiserver
- !!<dev-python/openpyxl-3.0.3[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # make sure they're not used
- rm tests/pypi-server-standalone.py || die
-
- # use system pypiserver instead of broken bundled one
- eapply "${FILESDIR}"/distlib-0.3.2-system-pypiserver.py || die
-
- # doesn't work with our patched pip
- sed -i -e '/PIP_AVAIL/s:True:False:' tests/test_wheel.py || die
-
- # broken with pypy3
- sed -i -e 's:test_custom_shebang:_&:' tests/test_scripts.py || die
- # broken with py3.11, doesn't look important
- sed -i -e 's:test_sequencer_basic:_&:' tests/test_util.py || die
- # https://bugs.gentoo.org/843839
- sed -i -e 's:test_interpreter_args:_&:' tests/test_scripts.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x SKIP_ONLINE=1
- local -x PYTHONHASHSEED=0
-
- # disable system-site-packages -- distlib has no deps, and is very
- # fragile to packages actually installed on the system
- sed -i -e '/system-site-packages/s:true:false:' \
- "${BUILD_DIR}/install${EPREFIX}/usr/bin/pyvenv.cfg" || die
-
- "${EPYTHON}" tests/test_all.py -v -x ||
- die "Tests failed with ${EPYTHON}"
-}