summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 23:52:05 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:11:25 +0100
commit1249cacd8d1a4a0e13f3667e6a4f92d05b562307 (patch)
tree2c3bf7b6c44cc44633d99e286555b7b0d7f63462 /dev-python/django-appconf/django-appconf-0.6.ebuild
parentdev-python/dj-database-url: Clean old up (diff)
downloadgentoo-1249cacd8d1a4a0e13f3667e6a4f92d05b562307.tar.gz
gentoo-1249cacd8d1a4a0e13f3667e6a4f92d05b562307.tar.bz2
gentoo-1249cacd8d1a4a0e13f3667e6a4f92d05b562307.zip
dev-python/django-appconf: Clean old up
Diffstat (limited to 'dev-python/django-appconf/django-appconf-0.6.ebuild')
-rw-r--r--dev-python/django-appconf/django-appconf-0.6.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/django-appconf/django-appconf-0.6.ebuild b/dev-python/django-appconf/django-appconf-0.6.ebuild
deleted file mode 100644
index 864e276edf86..000000000000
--- a/dev-python/django-appconf/django-appconf-0.6.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A helper class for handling configuration defaults of packaged apps gracefully"
-HOMEPAGE="https://github.com/jezdez/django-appconf http://django-appconf.readthedocs.org/"
-SRC_URI="https://github.com/jezdez/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND=">=dev-python/django-1.4.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/django-discover-runner[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/docs.patch )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- cd appconf/tests || die
- set -- django-admin.py test appconf --settings=appconf.test_settings
- echo "$@"
- "$@" || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}