summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-22 12:37:05 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-22 12:40:16 -0500
commit3a37cc95b76126bdeddbdea45f665a0b27f265a2 (patch)
treeacbd74fb99d8953bfaf9c103607b3db8151455c8 /dev-python/django-auth-ldap
parentsys-devel/clang: WebAssembly is no longer experimental in 8.0+ (diff)
downloadgentoo-3a37cc95b76126bdeddbdea45f665a0b27f265a2.tar.gz
gentoo-3a37cc95b76126bdeddbdea45f665a0b27f265a2.tar.bz2
gentoo-3a37cc95b76126bdeddbdea45f665a0b27f265a2.zip
dev-python/django-auth-ldap: 1.7 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 053417460962..2e3cdb85c954 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-1.2.2.tar.gz 131086 BLAKE2B 78f93eb24620907f5b5671972e2b80ec6e59cdc42a455c298bef4c3215616228735a0647b0646b683357bc16ea6d03488aa86626e2ad51211a382ee2d0482909 SHA512 676d1114faeb9a2956ed51c586afea7618c1bf62867d3525596599391f8327b8f22a075c4203311df88279c317ca37b9097b59e55a64330afee6eb1c5a9c9ac3
DIST django-auth-ldap-1.2.7.tar.gz 131431 BLAKE2B 03fac590118d25ad0d9d8a3ac5dd8bb24f138f193bf27ae85d4e2776be79bb31ca7efb278fd05ca1d45976116ca7ec79ec3b510ca380dd8912ce47f1522ad348 SHA512 2ca29bdceb4b2540f7c90c9dfdfd7a02f91e72cd44ae062cebff84199dab737ee69ada56269189ec0dd70ee7916c3373acba50866280ad080c4c68dd69dffb09
+DIST django-auth-ldap-1.7.0.tar.gz 48897 BLAKE2B b4b196e4cd0882a48d2437326cda57394963fa44a64a3cf5a0ff668bb86243da3979e2746e096a458a5bf1d3c8be687f3d3fe456f5a6b0ada11ebd1f4787e323 SHA512 6478b2ef43e6f49acff3dd2e3a2a462ae02a3f1475d5615ba2f14bfd5efe2b232a3d2008902177d90822fea6b096a05814a5f028f4eec5ee09c5e5a62793e73d
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
new file mode 100644
index 000000000000..12370642b88d
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}