summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 16:48:02 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit3383813980c26c582b5fb470c85974aebe67c8c1 (patch)
tree78cdd8534a67c4d5d5976e0b4eb7d158e19b1b54 /dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild
parentdev-python/py-amqp: Version Bump (diff)
downloadgentoo-3383813980c26c582b5fb470c85974aebe67c8c1.tar.gz
gentoo-3383813980c26c582b5fb470c85974aebe67c8c1.tar.bz2
gentoo-3383813980c26c582b5fb470c85974aebe67c8c1.zip
dev-python/django-debug-toolbar: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild')
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild
new file mode 100644
index 000000000000..39b3b90cebd6
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.7[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.1.10[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}