summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-27 23:32:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-28 00:16:04 +0200
commit855ee87d6f0c3df406e8c04936ed16c5069cb26d (patch)
tree0c748fcc416a50f2ce0f12609aa39269aa4a470f /dev-python/django-mptt
parentdev-python/django-mptt: Remove old (diff)
downloadgentoo-855ee87d6f0c3df406e8c04936ed16c5069cb26d.tar.gz
gentoo-855ee87d6f0c3df406e8c04936ed16c5069cb26d.tar.bz2
gentoo-855ee87d6f0c3df406e8c04936ed16c5069cb26d.zip
dev-python/django-mptt: Bump to 0.13.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-mptt')
-rw-r--r--dev-python/django-mptt/Manifest1
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/django-mptt/Manifest b/dev-python/django-mptt/Manifest
index 1b5f5f0aa232..cdc0defa20c1 100644
--- a/dev-python/django-mptt/Manifest
+++ b/dev-python/django-mptt/Manifest
@@ -1 +1,2 @@
DIST django-mptt-0.13.3.gh.tar.gz 303670 BLAKE2B 0185ecf3576ab7fe48ec4d7b2259e7cd88f2c5e3a8c96aa1ee555b7f0adabed4b787db84bcc4b2831746b410f0f58364df8fab9ce1768f1e1b9d1ff8a2869730 SHA512 602f45d4353dca80ec2285366c87eb60ff6a39a09990a041236f737371715166e9a8e360a83b4419c0ded7a206f73e4754de602aabef18f89e7db85ce8c651ea
+DIST django-mptt-0.13.4.gh.tar.gz 303688 BLAKE2B 66ae7a0e15a7ff281af2154f216970a6a9b249a713b3ae987f0fbdb60b95129fdfc96c05924c0285da33f11c59baf6e069830c3079c64164d838d9d34231a4a9 SHA512 86786763db060227b41e2e340df5d52062fb6e8c54f832611bc90d01102411d45dc217e8d84eece84ebbe4fc9727d06e7c368ae15c253aaf02117705dbae8c47
diff --git a/dev-python/django-mptt/django-mptt-0.13.4.ebuild b/dev-python/django-mptt/django-mptt-0.13.4.ebuild
new file mode 100644
index 000000000000..10262c58b326
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}