summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-22 23:36:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-22 23:36:57 +0200
commitd2a6d7d68b3ac42ce2e29c518aad99b8e9a5fdfa (patch)
tree97388192d201705a4a383b0d630621b651047ace /dev-python/django-mptt
parentnet-misc/networkmanager: Drop old versions (diff)
downloadgentoo-d2a6d7d68b3ac42ce2e29c518aad99b8e9a5fdfa.tar.gz
gentoo-d2a6d7d68b3ac42ce2e29c518aad99b8e9a5fdfa.tar.bz2
gentoo-d2a6d7d68b3ac42ce2e29c518aad99b8e9a5fdfa.zip
dev-python/django-mptt: Bump to 0.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-mptt')
-rw-r--r--dev-python/django-mptt/Manifest1
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/django-mptt/Manifest b/dev-python/django-mptt/Manifest
index 9f942579e7d4..bef1b93a80f0 100644
--- a/dev-python/django-mptt/Manifest
+++ b/dev-python/django-mptt/Manifest
@@ -1,2 +1,3 @@
DIST django-mptt-0.11.0.tar.gz 98300 BLAKE2B cbae24143007dfe8913aacf4cbe22bbccdf929617adc31640c2d429d6ea8be727a937be0aa8353e82862b9fe8c571397db4dd3877015eb17c2c5a56172cc66a5 SHA512 21af30007661db1474628b6f8af86a3f6de52494efe1aaf9235f8b1660ba153f0de3ad91ff979588e4b681b00b44652a05146df7d3951d6ee62da38a1900fd89
+DIST django-mptt-0.13.1.gh.tar.gz 302287 BLAKE2B 915e3066862be4d0883ba540cf584d917994ecbf83182726f5d39a40b61850e4ef1fade2c12325237f2c345de14ca6e54362712eb7bdbdf553eb6ebbf321075f SHA512 bc64d24f8d889109a054f270802f8ce6308c12bf3b9ebe1ba818d42e6c1f9d8904b8cad996e71e03c7f77ed80d912a7d8bb920cccc0e2fff170e754816367f40
DIST django-mptt-0.13.gh.tar.gz 302525 BLAKE2B 21b2fde5c81d83321bf7569d2064db87aec3c184f27cf3fc3bd34421be04212188e15f79a575b08aabb3a7b95d116bf3e5f0fb57c56cadf9ad2ac166e8e77845 SHA512 63dbb61dab59d42b5e747f35370a0840d40ed465979d1f93e66561cf4c0726635cae774f87e39cc1ac480847f3ccf0eb65dc8593759a0860d586e334fdd37256
diff --git a/dev-python/django-mptt/django-mptt-0.13.1.ebuild b/dev-python/django-mptt/django-mptt-0.13.1.ebuild
new file mode 100644
index 000000000000..10262c58b326
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}