summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-nose
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-nose')
-rw-r--r--dev-python/django-nose/Manifest3
-rw-r--r--dev-python/django-nose/django-nose-1.3.ebuild29
-rw-r--r--dev-python/django-nose/django-nose-1.4.1.ebuild36
-rw-r--r--dev-python/django-nose/django-nose-1.4.ebuild29
-rw-r--r--dev-python/django-nose/metadata.xml9
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/django-nose/Manifest b/dev-python/django-nose/Manifest
new file mode 100644
index 000000000000..76cc2b5b2ad3
--- /dev/null
+++ b/dev-python/django-nose/Manifest
@@ -0,0 +1,3 @@
+DIST django-nose-1.3.tar.gz 25149 SHA256 3667d26a41fec30364a0ef72580832ca5328802d553f6d6e72af5ac21cb36365 SHA512 0e7f18d32340f912fcde96c3ed4ff63caec71ad178f9bd01e61087a228d7e93ecfd87c5d320a66093bce438561638daacd586a4ecb3198573b28607d33eb853f WHIRLPOOL 0acbbe147c0e434ef641843d10f9781ef26f3dc428ba8e613165ed43d6f5d1dea27bf513d9efcbd551c38c7a1945ae3b06aafb0a6d01c8714479f0c4836f1863
+DIST django-nose-1.4.1.tar.gz 26792 SHA256 224dd1bfd8fcdb9f67256c5430147b4c0105d72f6ac8ce3bca6b486449ec6062 SHA512 9ba42767bdfb0c359d9c693c5a7775767ba1a56c54531e75ff2b97e2e12d2a9f535c771c5b076b9024f3662a4143f115aa4bd84b9844ce8cb71f99c47722dcef WHIRLPOOL 49c285867adcbf0b17a388bfd6c8cd2603d8c7b50ec162b088409c1a049e43718f9bc37167d914327d474f6177fb38e01797a80f0c47bc02fd7db31cbe7e8761
+DIST django-nose-1.4.tar.gz 26477 SHA256 26cef3c6f62df2eee955a25195de6f793881317c0f5fd1a1c6f9e22f351a9313 SHA512 2df1377146304bc0356e24a212bee8ee55c05ccaafcd6fceca4afe5ae528335192c4a89c842f4c2df6965965c9536f0862903aff2141139cfc83695b41d56e32 WHIRLPOOL 7da21678b2b955972f14dc806aac7c5615048b5edae96bdcc17ee4d1302d714519a223356398f89b0d512aa3aa6979567682dd81b8bb6c99cd7cdd340fa66293
diff --git a/dev-python/django-nose/django-nose-1.3.ebuild b/dev-python/django-nose/django-nose-1.3.ebuild
new file mode 100644
index 000000000000..99ac1a9e1248
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+RESTRICT="test" # missing south
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? ( ${RDEPEND}
+# >=dev-python/south-0.7[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" testapp/runtests.py
+}
diff --git a/dev-python/django-nose/django-nose-1.4.1.ebuild b/dev-python/django-nose/django-nose-1.4.1.ebuild
new file mode 100644
index 000000000000..5cc34b373c9a
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # The testsuite currently broken See notes below
+
+RDEPEND=">=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? ( ${RDEPEND}
+# >=dev-python/south-0.7[${PYTHON_USEDEP}] )"
+# South currently doesn't support any versions of django in portage
+# that support python3. They are masked as is south which appears may be deprecated
+
+python_test() {
+ # https://github.com/django-nose/django-nose/issues/227
+ # Running tests by the bash script runtests.sh reveals a missing
+ # folder. Use of runtests.py works only for py2.7 due to
+ # south supporting only old versions of django.
+ # The testsuite has a massive rewrite set in the issue listed above.
+ ./runtests.sh
+# "${PYTHON}" testapp/runtests.py broken
+}
diff --git a/dev-python/django-nose/django-nose-1.4.ebuild b/dev-python/django-nose/django-nose-1.4.ebuild
new file mode 100644
index 000000000000..17870774ebdf
--- /dev/null
+++ b/dev-python/django-nose/django-nose-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+RESTRICT="test" # missing south now
+
+inherit distutils-r1
+
+DESCRIPTION="Django test runner that uses nose"
+HOMEPAGE="https://github.com/jbalogh/django-nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/nose-1.2.1[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? ( ${RDEPEND}
+# >=dev-python/south-0.7[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" testapp/runtests.py
+}
diff --git a/dev-python/django-nose/metadata.xml b/dev-python/django-nose/metadata.xml
new file mode 100644
index 000000000000..c3eb3f767705
--- /dev/null
+++ b/dev-python/django-nose/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-nose</remote-id>
+ <remote-id type="github">jbalogh/django-nose</remote-id>
+ </upstream>
+</pkgmetadata>