summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 09:23:20 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 11:24:40 +0100
commitefd268300d4ebfa851eded23fd415ca25f3ed8ad (patch)
tree04901101df1e0ed3bd6fbcb3267df4b9fe8351ba /dev-python/django-pipeline
parentdev-python/hypothesis: Version Bump (diff)
downloadgentoo-efd268300d4ebfa851eded23fd415ca25f3ed8ad.tar.gz
gentoo-efd268300d4ebfa851eded23fd415ca25f3ed8ad.tar.bz2
gentoo-efd268300d4ebfa851eded23fd415ca25f3ed8ad.zip
dev-python/django-pipeline: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/Manifest1
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.5.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
index 2225d0085dc3..6c2941d1e4db 100644
--- a/dev-python/django-pipeline/Manifest
+++ b/dev-python/django-pipeline/Manifest
@@ -1 +1,2 @@
DIST django-pipeline-1.3.26.tar.gz 41054 SHA256 58433fc07cc81f213686b892caeb8d17d6ed4e00444ef95b35f21a5a3cc6357e SHA512 106c89e6a5509305548f6169f9b38d3a288bdf260c4b933ac1372c8471e897b8f6109cdecf70a4f77dff670e2b97abe4ed990903abfc188a59600189d0473284 WHIRLPOOL 7ead1f6dbc6df1a5c4b26869e6b4ae73cd416ed52f22ba1ff16b57a295f476c7973a56af9c05d1b50097e82dcd286207f648920b3acadd88fc40ad26aae10285
+DIST django-pipeline-1.5.4.tar.gz 41115 SHA256 5e387e2a92880f67c299ade766577c8c66485ffb867fbcffb73f696ddb9b245d SHA512 2393d1b44ca38416589b5b0e731b66e4e95be0b1adcba89fd76905975df0f35857bcbe019fc239127c578ab3a1b77cec5892298068de3634b2020d79e74aa1ad WHIRLPOOL 79e63b07751fb4c216004ca8aa695690b2006346f6b65e075d59484c6411c2f29c7b138f9e12f2e523e8c68e68f11398e183ed4a6816b5a47ef833dbb22b2b02
diff --git a/dev-python/django-pipeline/django-pipeline-1.5.4.ebuild b/dev-python/django-pipeline/django-pipeline-1.5.4.ebuild
new file mode 100644
index 000000000000..9f9095a446d4
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="https://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
+
+# PyPi releases lack docs/ subdir:
+# https://github.com/cyberdelia/django-pipeline/pull/254
+SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/django-1.7[${PYTHON_USEDEP}]
+ dev-python/jsmin[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+# As usual for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/cyberdelia/django-pipeline/issues/381
+ PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ export PIPELINE_JS_COMPRESSOR = 'pipeline.compressors.jsmin.JSMinCompressor'
+ distutils-r1_python_install
+}