summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:20:56 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:23:02 -0600
commita0bd3410eff04c0f011b60740721cbb1fb4deac7 (patch)
treee5e38082b15b9f007a322cebea198ac89ffbab83 /dev-python/django-prometheus
parentpackage.mask: Last rite app-i18n/zhcon (diff)
downloadgentoo-a0bd3410eff04c0f011b60740721cbb1fb4deac7.tar.gz
gentoo-a0bd3410eff04c0f011b60740721cbb1fb4deac7.tar.bz2
gentoo-a0bd3410eff04c0f011b60740721cbb1fb4deac7.zip
dev-python/django-prometheus: 1.1.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest1
-rw-r--r--dev-python/django-prometheus/django-prometheus-1.1.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 8fe0bdcce319..0a58d0241892 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1 +1,2 @@
DIST django-prometheus-1.0.15.tar.gz 13708 BLAKE2B 64d72224da9cb481108ad17ed1409d97108353a39894f824428743f3ee894292352de4d4beebf1984294e34cea7b6d0144c5066d0fe5cca7d9c682f9410355d3 SHA512 48794f6d07ebdd3487060e62e808a66a97630045433dd91a27f1095f79a72197124c44c5d178c89785b8d048e8e828f84804c789cb5c2f0a053cf18864cde6eb
+DIST django-prometheus-1.1.0.tar.gz 18237 BLAKE2B 9b32e95750b57122a42d2e0b7f257407885a08db446e013933d2e81a525bf99f872f82c7f081f4c8c3c18f899c48ffa947ac8a89b751babaa8a8348f3f50b757 SHA512 9fa8c0175d1f8f714954f1c16715007e5c074568cc703d57e62f24686db1e16c40fc02244c4f9721995636723d90435bb3b2348282530d969b543bce39e65774
diff --git a/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild b/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild
new file mode 100644
index 000000000000..abb290d08b4e
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Library to export django metrics for prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"