summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-21 17:31:42 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:18:56 +0000
commitc555e4cf9f23a7c2c4d876c9fa9689c35025f975 (patch)
tree9f09dfcbc1db9780cac077614a6149784d6d190d /dev-python/django-prometheus
parentmedia-sound/marrie: Sync live ebuild (diff)
downloadgentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.tar.gz
gentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.tar.bz2
gentoo-c555e4cf9f23a7c2c4d876c9fa9689c35025f975.zip
dev-python/django-prometheus: Bump to 2.1.0
Closes: https://bugs.gentoo.org/767010 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest1
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.1.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 6494f3455ee9..706de121090b 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1 +1,2 @@
DIST django-prometheus-2.0.0.tar.gz 20028 BLAKE2B 272f192cc0ee4492fa6dbbb65ba6696fdf8fbddc0724290d9b55e5aedb740c2c92cb609969240004b4faca4569580ab451284c2f4bbde589ee61bb96ec448ff3 SHA512 8345c23c8032f0dbecd8e801bd6673e7e3804003ebee0a15b0c8ce3b2d4c6b6f47e7c41e33df2b18a0497eb453972d8b231b88fb51184fafc58d306a9430fdec
+DIST django-prometheus-2.1.0.tar.gz 24615 BLAKE2B 381aa345fac29e71e2b883fb485dce1d6ca3f13fc863d6ca9a62d5cd8f605f8cca727fbc3a3946e707d80f89d7fbaf544610cfb4857a45bc3dc13eeb22aeb4d6 SHA512 0c102467b99df409e31f99fb77d16558bd01c9c11f04ac0f80b59e486bc6e03979e16785083980c43ee3caad26b7a6bf618f9592fcca788ec2793a30d6b44241
diff --git a/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
new file mode 100644
index 000000000000..108c87dc5cd3
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}