summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 16:19:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 16:20:39 +0200
commit275077fcb686eebaa53ce45210de63fe1762ce8a (patch)
tree4bef7f26fbbf90e95fbc5ef7f6dcd4885bc44a96 /dev-python/django-tagging/django-tagging-0.5.0.ebuild
parentpackage.mask: Last rite dev-python/django-spurl (diff)
downloadgentoo-275077fcb686eebaa53ce45210de63fe1762ce8a.tar.gz
gentoo-275077fcb686eebaa53ce45210de63fe1762ce8a.tar.bz2
gentoo-275077fcb686eebaa53ce45210de63fe1762ce8a.zip
dev-python/django-tagging: Bump to 0.5.0, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-tagging/django-tagging-0.5.0.ebuild')
-rw-r--r--dev-python/django-tagging/django-tagging-0.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/django-tagging/django-tagging-0.5.0.ebuild b/dev-python/django-tagging/django-tagging-0.5.0.ebuild
new file mode 100644
index 000000000000..f20e767c32e7
--- /dev/null
+++ b/dev-python/django-tagging/django-tagging-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic tagging application for Django"
+HOMEPAGE="https://pypi.org/project/django-tagging/
+ https://github.com/Fantomas42/django-tagging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/django-1.0[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tagging.tests.settings
+ local -x PYTHONPATH=.
+ django-admin test -v 2 tagging || die "Tests failed with ${EPYTHON}"
+}