summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:38:31 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:39:02 -0600
commitbd6464dbef39670ed6aa71402cf8c72a39f2b334 (patch)
tree955e167609d33f7c16188bd2c420c16c2f1bf396 /dev-python/django-timezone-field
parentdev-python/diff-cover: Drop 1.0.4 (diff)
downloadgentoo-bd6464dbef39670ed6aa71402cf8c72a39f2b334.tar.gz
gentoo-bd6464dbef39670ed6aa71402cf8c72a39f2b334.tar.bz2
gentoo-bd6464dbef39670ed6aa71402cf8c72a39f2b334.zip
dev-python/django-timezone-field: 4.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-4.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index 3a32750c5025..77e0d89af0d1 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1 +1,2 @@
DIST django-timezone-field-3.0.tar.gz 6217 BLAKE2B 4f4214ecd142284f7da89711535834c8d4d931a2532ff54181e6b072d7e636bcfaa1fe0cab5421d047fdd6d6ab472246054dd8bec8bb0c987df6e336aa269e96 SHA512 624e5b1e6b75ec40252ea7137608d9f62a5fbba1a136068c0c4c5e6192afa9756456cfbcba5ae3b00980f8e0ab44e507226815b25196bb58a39789a75036789b
+DIST django-timezone-field-4.0.tar.gz 6866 BLAKE2B 1904dbdc6454109ab00df5008d36a9db9e8dc68215d1824c980ef82711871747d7b51a263d591968494511a33bc4325930dd7d87ba4b62d9386c78c5508d7680 SHA512 d928cc22d45f027b9d5776272cd8bc03b3d7e403d4ade293973e25a7ef96ab1ff6ccaa5bfce2900f579b52f5e8cd6c581054e944440d05b774457faf4ca9c9b1
diff --git a/dev-python/django-timezone-field/django-timezone-field-4.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-4.0.ebuild
new file mode 100644
index 000000000000..907886a12e6e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="https://github.com/mfogel/django-timezone-field"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"