summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-15 15:24:04 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-15 17:08:45 -0500
commitc2ea5bae5a3f2fe0a59d2094da8eac2d353bd01b (patch)
tree3536ddd3a53ddd36b4829a411b89a56a61bfa418 /dev-python/django-timezone-field
parentdev-python/django-taggit-serializer: The django taggit serializer for (diff)
downloadgentoo-c2ea5bae5a3f2fe0a59d2094da8eac2d353bd01b.tar.gz
gentoo-c2ea5bae5a3f2fe0a59d2094da8eac2d353bd01b.tar.bz2
gentoo-c2ea5bae5a3f2fe0a59d2094da8eac2d353bd01b.zip
dev-python/django-timezone-field: db and form fields for pytz timezone objects
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-timezone-field')
-rw-r--r--dev-python/django-timezone-field/Manifest1
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-3.0.ebuild20
-rw-r--r--dev-python/django-timezone-field/metadata.xml8
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
new file mode 100644
index 000000000000..3a32750c5025
--- /dev/null
+++ b/dev-python/django-timezone-field/Manifest
@@ -0,0 +1 @@
+DIST django-timezone-field-3.0.tar.gz 6217 BLAKE2B 4f4214ecd142284f7da89711535834c8d4d931a2532ff54181e6b072d7e636bcfaa1fe0cab5421d047fdd6d6ab472246054dd8bec8bb0c987df6e336aa269e96 SHA512 624e5b1e6b75ec40252ea7137608d9f62a5fbba1a136068c0c4c5e6192afa9756456cfbcba5ae3b00980f8e0ab44e507226815b25196bb58a39789a75036789b
diff --git a/dev-python/django-timezone-field/django-timezone-field-3.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-3.0.ebuild
new file mode 100644
index 000000000000..9385b768fc8e
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for pytz timezone objects"
+HOMEPAGE="http://github.com/mfogel/django-timezone-field"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-1.8[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-timezone-field/metadata.xml b/dev-python/django-timezone-field/metadata.xml
new file mode 100644
index 000000000000..c36c37139fad
--- /dev/null
+++ b/dev-python/django-timezone-field/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>