summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-xslt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-xslt')
-rw-r--r--dev-python/django-xslt/Manifest2
-rw-r--r--dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild36
-rw-r--r--dev-python/django-xslt/metadata.xml12
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-xslt/Manifest b/dev-python/django-xslt/Manifest
new file mode 100644
index 000000000000..15d192b0f1fb
--- /dev/null
+++ b/dev-python/django-xslt/Manifest
@@ -0,0 +1,2 @@
+DIST django-xslt-0.4.5.tar.gz 15717 SHA256 db3bad334310e13a37391cbd52fc1b0432165d9a97494c9413008c0fc8023ccb SHA512 25f3268d5eae29326ee93b5c4189389577bbf282e9f9007798de2ce96c6420d240c07e6a2abbbc57ce0bb4abb3aef557b545948a02b36a118afaefb30ca5a2b4 WHIRLPOOL 9654a2a3d7baf8ed3de9061cc43872db9e0a72f9331cce5bd804d5395611a0421d2cbec7f7a94fd73f48d439a702b0fbb98424ce15274511183398e317289fab
+DIST django-xslt-demoapp-0.4.5_p20120427.tar.bz2 5506 SHA256 a448e2cb6db716199915a1bc3a49ab28388cdb41d4ad3e7c6a0127e82143766f SHA512 200832172eac9c2729816c800fc32376ae62be2d832a398538054dca875fbedc41a300618f37f4d2b1cc36f36be20a6cbd86cc7f66e5ada476309e734c3f578d WHIRLPOOL 1afabf88e61bdb1e545bd84a0890953cd59d6e2811760e1d4c3f93307fd2f01b915404867af42265e19daa58c10cdb7b0538e31c468b8852cd960107063f00c0
diff --git a/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild b/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..fab013c4e28f
--- /dev/null
+++ b/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( http://dev.gentoo.org/~tampakrap/tarballs/${PN}-demoapp-0.4.5_p20120427.tar.bz2 )"
+
+DESCRIPTION="an XSLT template system for Django"
+HOMEPAGE="http://pypi.python.org/pypi/django-xslt/"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ export SECRET_KEY="green"
+ pushd "${WORKDIR}/demoapp" > /dev/null
+ if ! "${PYTHON}" -c "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" \
+ manage.py test; then
+ die "tests failed under ${EPYTHON}"
+ else
+ einfo "tests passed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/django-xslt/metadata.xml b/dev-python/django-xslt/metadata.xml
new file mode 100644
index 000000000000..7367468525ec
--- /dev/null
+++ b/dev-python/django-xslt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-xslt</remote-id>
+ </upstream>
+</pkgmetadata>