summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-01 14:49:50 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-01 15:47:26 +0200
commit4402f6ad681a96339ecf9710b6fc9c972276ff8e (patch)
tree483dbca81fb4de3a99fe22a2ad515bb322422718 /dev-python/django
parentdev-python/django: Bump to 2.2.14 (diff)
downloadgentoo-4402f6ad681a96339ecf9710b6fc9c972276ff8e.tar.gz
gentoo-4402f6ad681a96339ecf9710b6fc9c972276ff8e.tar.bz2
gentoo-4402f6ad681a96339ecf9710b6fc9c972276ff8e.zip
dev-python/django: Bump to 3.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-3.0.8.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index e9ab688bde58..498d61ad4f8e 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -4,3 +4,4 @@ DIST Django-2.2.13.tar.gz 8879757 BLAKE2B 4a7986805c6a3674d47aa82b97f31ae63968dd
DIST Django-2.2.14.tar.gz 9022051 BLAKE2B 397f1de35f645da9964581d494d933ce2327915315049997aaed238f27214e4fead8c50e779052eafb3d237e065ef47f2d3f151552f712b6348ed23b75d25e52 SHA512 48ad065df161300920abe0c28c3f79cebe536de00fe60c8a7633caee149e0632aa564a848172bad0f254f2a98194cb625a5c169e51a89f3cab95c1213cfe485d
DIST Django-3.0.6.tar.gz 9070990 BLAKE2B 9f918f64baecc5fe18ec08293da0f81a5e6ba9dc034b7e43f11ac9e67fa8d16c155878342babad9fca8ed30caf5ec3335756e2e0312c463b46a23b4db92fd4a0 SHA512 4c92c51386919c389037d6c6d1de3cb6ec443bd1f216f20797fb20fb24ea8d021701a03805ba693deadfa82b1aee38ae0d7fc03cae94cd744b1d1fa47ddc46ad
DIST Django-3.0.7.tar.gz 8947502 BLAKE2B c26752f41f04f23ea1db9863d0919c17ed27b75133e22cc342e453e40077f05f6458f8edd290bfdcf828a181e38d89a1b4faeaa9cb44176ff0f7d67910d6b9df SHA512 566a78c3686baaea2ea8f2db2c1762a78ec5e5ae44f0be43f49c83899c2a0a9d1b2297a05ce8f4bc6bc580c494dde66bb2be47a8269cce3e1b007fedd857e5d3
+DIST Django-3.0.8.tar.gz 9080731 BLAKE2B b3276527c9c5eba18b380204c498ebd5724e5211640ead9e05284eb013f907ce6799125b29e2030bc37ecd5a1022e6eb3f193eca5e2c6520adef630d6d2114a9 SHA512 92d169fb37883355f1898fc13b54b6732ec14d71f77e4b91db30dd9bfb5df8b34c1c9566af6ddc37e00a9e3eadd38b6a51ff604a4da4285167f66b55215be301
diff --git a/dev-python/django/django-3.0.8.ebuild b/dev-python/django/django-3.0.8.ebuild
new file mode 100644
index 000000000000..fbc688b75cbc
--- /dev/null
+++ b/dev-python/django/django-3.0.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.6-bashcomp.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ echo ""
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}